summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquellen2018-03-19 16:42:34 +0100
committerquellen2018-03-19 16:42:34 +0100
commit80102be1702991bb74fb25a6af53b2ac0c3f4ccd (patch)
tree5c29405e4f8d258157110a0f9c950c84b892841d
parentc8bd6a2cd118fc6a71712d55b4190789339a9b67 (diff)
downloadaur-80102be1702991bb74fb25a6af53b2ac0c3f4ccd.tar.gz
add libretro-core-info depend
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a8b56a56985..9b7d96c97429 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,8 +12,9 @@ pkgbase = libretro-fsuae-git
license = GPL3
makedepends = git
depends = zlib
- depends = libretro-core-info
source = git+https://github.com/libretro/libretro-fsuae.git
+ source = https://raw.github.com/libretro/libretro-super/master/dist/info/fsuae_libretro.info
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = libretro-fsuae-git
diff --git a/PKGBUILD b/PKGBUILD
index 6565d4ea3614..daa1e8445603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,15 @@ arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="https://github.com/libretro/libretro-fsuae"
license=('GPL3')
groups=('libretro')
-depends=('zlib' 'libretro-core-info')
+depends=('zlib')
makedepends=('git')
_libname=fsuae_libretro
_gitname=libretro-fsuae
-source=("git+https://github.com/libretro/${_gitname}.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/libretro/${_gitname}.git"
+ "https://raw.github.com/libretro/libretro-super/master/dist/info/${_libname}.info")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "${_gitname}"
@@ -34,4 +36,5 @@ build() {
package() {
install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+ install -Dm644 "${_libname}.info" "${pkgdir}/usr/share/libretro/info/${_libname}.info"
} \ No newline at end of file