summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-08-08 16:55:14 -0700
committerJohn ShaggyTwoDope Jenkins2015-08-08 16:55:14 -0700
commit722c23891c3e20d6e84f92554be21441b132a428 (patch)
treef20a5587ab3a5f44bb4a042919c7e9cdf9d1c2f7
downloadaur-722c23891c3e20d6e84f92554be21441b132a428.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63587900d5aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libretro-genesis-plus-gx-git
+ pkgdesc = libretro implementation of Genesis Plus GX. (Sega Master System/Sega Game Gear/Sega Mega Drive/Sega Genesis/Sega CD)
+ pkgver = 927.5b3e8c4
+ pkgrel = 1
+ url = https://github.com/libretro/Genesis-Plus-GX
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ license = custom
+ makedepends = git
+ depends = zlib
+ conflicts = libretro-genplus-git
+ source = git+https://github.com/libretro/Genesis-Plus-GX.git
+ source = https://raw.github.com/libretro/libretro-super/master/dist/info/genesis_plus_gx_libretro.info
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = libretro-genesis-plus-gx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c41b42de1ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer : Johnathan Jenkins <twodopeshaggy@gmail.com>
+# Contributor: prettyvanilla <prettyvanilla@posteo.at>
+# Contributor: almostalive <almostalive2003 at gmail dot com>
+
+pkgname=libretro-genesis-plus-gx-git
+pkgver=927.5b3e8c4
+pkgrel=1
+pkgdesc="libretro implementation of Genesis Plus GX. (Sega Master System/Sega Game Gear/Sega Mega Drive/Sega Genesis/Sega CD)"
+arch=('i686' 'x86_64' 'arm' 'armv6h')
+url="https://github.com/libretro/Genesis-Plus-GX"
+license=('custom')
+conflicts=('libretro-genplus-git')
+depends=('zlib')
+makedepends=('git')
+
+_libname=genesis_plus_gx_libretro
+_gitname=Genesis-Plus-GX
+source=("git+https://github.com/libretro/${_gitname}.git"
+ "https://raw.github.com/libretro/libretro-super/master/dist/info/${_libname}.info")
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${_gitname}"
+ make -f Makefile.libretro
+}
+
+package() {
+ install -Dm644 "${_gitname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+ install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+ install -Dm644 "${_libname}.info" "${pkgdir}/usr/lib/libretro/${_libname}.info"
+}