summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-03-02 13:01:10 +0100
committerAlexandre Bouvier2021-03-02 13:01:10 +0100
commit41545f34f523fd3306c86f6f479b312880902c34 (patch)
treef0aa9b100cb4ff6c57adef3508184b12fbeea023
downloadaur-41545f34f523fd3306c86f6f479b312880902c34.tar.gz
r1530.fbbac38
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..178aa8a2cb9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libretro-genesis-plus-gx-wide-git
+ pkgdesc = Widescreen modification of Genesis Plus GX
+ pkgver = r1530.fbbac38
+ pkgrel = 1
+ url = https://github.com/libretro/Genesis-Plus-GX-Wide
+ arch = x86_64
+ groups = libretro
+ license = custom
+ makedepends = git
+ depends = libretro-core-info
+ depends = glibc
+ provides = libretro-genesis-plus-gx-wide
+ conflicts = libretro-genesis-plus-gx-wide
+ source = libretro-genesis-plus-gx-wide::git+https://github.com/libretro/Genesis-Plus-GX-Wide.git
+ md5sums = SKIP
+
+pkgname = libretro-genesis-plus-gx-wide-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0e85970aa00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# shellcheck shell=bash disable=SC2034,SC2164
+_pkgname=libretro-genesis-plus-gx-wide
+pkgname=$_pkgname-git
+pkgver=r1530.fbbac38
+pkgrel=1
+pkgdesc="Widescreen modification of Genesis Plus GX"
+arch=('x86_64')
+url="https://github.com/libretro/Genesis-Plus-GX-Wide"
+license=('custom')
+groups=('libretro')
+depends=('libretro-core-info' 'glibc')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ make -f Makefile.libretro
+}
+
+package() {
+ cd $_pkgname
+ # shellcheck disable=SC2154
+ install -Dm644 -t "$pkgdir"/usr/lib/libretro genesis_plus_gx_wide_libretro.so
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$_pkgname LICENSE.txt
+}