summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-04-07 02:11:05 +0200
committerAlexandre Bouvier2022-04-07 02:11:05 +0200
commit7fb4a9c8faa2e098a7e01c4a944d41f7c28c7589 (patch)
treed4a7311084d054efd5740b631345d153cc5330c6
parent9534ff051b890f29ab1d3638bde2c75f63c63b85 (diff)
downloadaur-7fb4a9c8faa2e098a7e01c4a944d41f7c28c7589.tar.gz
update to r1598.fa71a16
* add more arch * unbundle libchdr * remove hardcoded optimization flags
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
-rw-r--r--unbundle-libs.patch61
3 files changed, 87 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5762346957ba..33569d839f10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,26 @@
pkgbase = libretro-genesis-plus-gx-wide-git
pkgdesc = Sega CD/Game Gear/Master System/Mega Drive/SG-1000 core
- pkgver = r1539.73c298b
- pkgrel = 3
+ pkgver = r1598.fa71a16
+ pkgrel = 1
url = https://github.com/libretro/Genesis-Plus-GX-Wide
- arch = arm
- arch = armv6h
+ arch = aarch64
arch = armv7h
+ arch = i486
arch = i686
+ arch = pentium4
arch = x86_64
groups = libretro
license = custom
makedepends = git
depends = glibc
+ depends = libchdr
depends = libretro-core-info
depends = libvorbis
provides = libretro-genesis-plus-gx-wide
conflicts = libretro-genesis-plus-gx-wide
source = libretro-genesis-plus-gx-wide::git+https://github.com/libretro/Genesis-Plus-GX-Wide.git
+ source = unbundle-libs.patch
b2sums = SKIP
+ b2sums = e56f791aeaf8650e777985780db8990603d5fc164a0cb6fcfe00a9a0d459be754f15a34ce73ebbb5a8a82cb7fedac34608616f7b05d2ccb9dfca0660cf828a3e
pkgname = libretro-genesis-plus-gx-wide-git
diff --git a/PKGBUILD b/PKGBUILD
index c3ce76bf0d6c..ecb9c3fc9b18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,37 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=libretro-genesis-plus-gx-wide
pkgname=$_pkgname-git
-pkgver=r1539.73c298b
-pkgrel=3
+pkgver=r1598.fa71a16
+pkgrel=1
pkgdesc="Sega CD/Game Gear/Master System/Mega Drive/SG-1000 core"
-arch=('arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
+arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://github.com/libretro/Genesis-Plus-GX-Wide"
license=('custom')
groups=('libretro')
-depends=('glibc' 'libretro-core-info' 'libvorbis')
+depends=('glibc' 'libchdr' 'libretro-core-info' 'libvorbis')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+$url.git")
-b2sums=('SKIP')
+source=(
+ "$_pkgname::git+$url.git"
+ 'unbundle-libs.patch'
+)
+b2sums=(
+ 'SKIP'
+ 'e56f791aeaf8650e777985780db8990603d5fc164a0cb6fcfe00a9a0d459be754f15a34ce73ebbb5a8a82cb7fedac34608616f7b05d2ccb9dfca0660cf828a3e'
+)
pkgver() {
cd $_pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd $_pkgname
+ patch -Np1 < ../unbundle-libs.patch
+ sed -i 's/-O[0123s]//;s/-Ofast//' Makefile.libretro
+}
+
build() {
make -C $_pkgname -f Makefile.libretro SHARED_LIBVORBIS=1
}
diff --git a/unbundle-libs.patch b/unbundle-libs.patch
new file mode 100644
index 000000000000..8113ef5c55e8
--- /dev/null
+++ b/unbundle-libs.patch
@@ -0,0 +1,61 @@
+diff --git a/core/cd_hw/cdd.h b/core/cd_hw/cdd.h
+index f3e8002..f68c2b6 100644
+--- a/core/cd_hw/cdd.h
++++ b/core/cd_hw/cdd.h
+@@ -47,8 +47,8 @@
+ #endif
+
+ #if defined(USE_LIBCHDR)
+-#include "libchdr/src/chd.h"
+-#include "libchdr/src/cdrom.h"
++#include <libchdr/chd.h>
++#include <libchdr/cdrom.h>
+ #endif
+
+ #define cdd scd.cdd_hw
+diff --git a/libretro/Makefile.common b/libretro/Makefile.common
+index a527d47..f8d99b2 100644
+--- a/libretro/Makefile.common
++++ b/libretro/Makefile.common
+@@ -22,26 +22,8 @@ ifeq ($(HOOK_CPU), 1)
+ endif
+
+ ifeq ($(HAVE_CHD), 1)
+- INCFLAGS += \
+- -I$(LIBRETRO_DEPS_DIR)/libchdr/include \
+- -I$(LIBRETRO_DEPS_DIR)/lzma-19.00/include \
+- -I$(LIBRETRO_DEPS_DIR)/zlib-1.2.11
+- SOURCES_C += \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/Alloc.c \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/Bra86.c \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/BraIA64.c \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/CpuArch.c \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/Delta.c \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/LzFind.c \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/Lzma86Dec.c \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/LzmaDec.c \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/LzmaEnc.c \
+- $(LIBRETRO_DEPS_DIR)/lzma-19.00/src/Sort.c \
+- $(LIBRETRO_DEPS_DIR)/libchdr/src/libchdr_bitstream.c \
+- $(LIBRETRO_DEPS_DIR)/libchdr/src/libchdr_cdrom.c \
+- $(LIBRETRO_DEPS_DIR)/libchdr/src/libchdr_chd.c \
+- $(LIBRETRO_DEPS_DIR)/libchdr/src/libchdr_flac.c \
+- $(LIBRETRO_DEPS_DIR)/libchdr/src/libchdr_huffman.c
++ INCFLAGS += $(shell pkg-config --cflags libchdr)
++ LIBS += $(shell pkg-config --libs libchdr)
+ endif
+
+ SOURCES_C += $(foreach dir,$(GENPLUS_SRC_DIR),$(wildcard $(dir)/*.c))
+@@ -74,12 +56,6 @@ SOURCES_C += \
+ $(LIBRETRO_COMM_DIR)/cdrom/cdrom.c \
+ $(LIBRETRO_COMM_DIR)/vfs/vfs_implementation_cdrom.c
+ endif
+-SOURCES_C += \
+- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/adler32.c \
+- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/inffast.c \
+- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/inflate.c \
+- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/inftrees.c \
+- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/zutil.c
+
+ endif
+