summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2024-01-14 01:12:20 +0100
committerAlexandre Bouvier2024-01-14 01:12:20 +0100
commitbc20aacce07944a2d6ba3e1944e6980d45ff55c6 (patch)
treebdadeb90a92e449d3314a2be2110d98d744c5309
parent4d5fc8badae4f5c595141879d86593a35ce38968 (diff)
downloadaur-bc20aacce07944a2d6ba3e1944e6980d45ff55c6.tar.gz
update to 1.0.1.r0.g949bb4d
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD47
2 files changed, 68 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0447b04e73c..e3b65d1bd001 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libretro-melondsds-git
pkgdesc = Nintendo DS core
- pkgver = 0.8.7.r23.gd13a8a2
+ pkgver = 1.0.1.r0.g949bb4d
pkgrel = 1
url = https://github.com/JesseTG/melonds-ds
arch = aarch64
@@ -10,16 +10,38 @@ pkgbase = libretro-melondsds-git
arch = pentium4
arch = x86_64
groups = libretro
- license = GPL3
+ license = GPL-3.0-or-later
makedepends = cmake>=3.19
makedepends = git
makedepends = libgl
depends = gcc-libs
depends = glibc
depends = libretro-core-info>=1.16.0.3.r2
- provides = libretro-melondsds=0.8.7.r23.gd13a8a2
+ provides = libretro-melondsds=1.0.1.r0.g949bb4d
conflicts = libretro-melondsds
source = libretro-melondsds::git+https://github.com/JesseTG/melonds-ds.git
+ source = git+https://github.com/melonDS-emu/melonDS.git
+ source = git+https://github.com/libretro/libretro-common.git
+ source = git+https://github.com/andoalon/embed-binaries.git
+ source = git+https://github.com/g-truc/glm.git
+ source = git+https://gitlab.freedesktop.org/slirp/libslirp.git
+ source = git+https://github.com/RobLoach/pntr.git
+ source = git+https://github.com/fmtlib/fmt.git
+ source = git+https://github.com/yohhoy/yamc.git
+ source = git+https://github.com/martinmoene/span-lite.git
+ source = git+https://github.com/HowardHinnant/date.git
+ source = git+https://github.com/madler/zlib.git
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
b2sums = SKIP
pkgname = libretro-melondsds-git
diff --git a/PKGBUILD b/PKGBUILD
index d752552c5e83..b5c6dcedb2f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,45 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=libretro-melondsds
pkgname=$_pkgname-git
-pkgver=0.8.7.r23.gd13a8a2
+pkgver=1.0.1.r0.g949bb4d
pkgrel=1
pkgdesc="Nintendo DS core"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://github.com/JesseTG/melonds-ds"
-license=('GPL3')
+license=('GPL-3.0-or-later')
groups=('libretro')
depends=('gcc-libs' 'glibc' 'libretro-core-info>=1.16.0.3.r2')
makedepends=('cmake>=3.19' 'git' 'libgl')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=("$_pkgname::git+$url.git")
-b2sums=('SKIP')
+source=(
+ "$_pkgname::git+$url.git"
+ 'git+https://github.com/melonDS-emu/melonDS.git'
+ 'git+https://github.com/libretro/libretro-common.git'
+ 'git+https://github.com/andoalon/embed-binaries.git'
+ 'git+https://github.com/g-truc/glm.git'
+ 'git+https://gitlab.freedesktop.org/slirp/libslirp.git'
+ 'git+https://github.com/RobLoach/pntr.git'
+ 'git+https://github.com/fmtlib/fmt.git'
+ 'git+https://github.com/yohhoy/yamc.git'
+ 'git+https://github.com/martinmoene/span-lite.git'
+ 'git+https://github.com/HowardHinnant/date.git'
+ 'git+https://github.com/madler/zlib.git'
+)
+b2sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
cd $_pkgname
@@ -21,10 +47,22 @@ pkgver() {
}
build() {
+ # shellcheck disable=SC2154
cmake -S $_pkgname -B build \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
-DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
+ -DDATE_REPOSITORY_URL="$srcdir"/date \
+ -DEMBED_BINARIES_REPOSITORY_URL="$srcdir"/embed-binaries \
+ -DFMT_REPOSITORY_URL="$srcdir"/fmt \
+ -DGLM_REPOSITORY_URL="$srcdir"/glm \
+ -DLIBRETRO_COMMON_REPOSITORY_URL="$srcdir"/libretro-common \
+ -DLIBSLIRP_REPOSITORY_URL="$srcdir"/libslirp \
+ -DMELONDS_REPOSITORY_URL="$srcdir"/melonDS \
+ -DPNTR_REPOSITORY_URL="$srcdir"/pntr \
+ -DSPAN_LITE_REPOSITORY_URL="$srcdir"/span-lite \
+ -DYAMC_REPOSITORY_URL="$srcdir"/yamc \
+ -DZLIB_REPOSITORY_URL="$srcdir"/zlib \
-Wno-dev
cmake --build build
}
@@ -33,4 +71,5 @@ package() {
depends+=('libOpenGL.so')
# shellcheck disable=SC2154
install -D -t "$pkgdir"/usr/lib/libretro build/src/libretro/melondsds_libretro.so
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname build/melondsds-LICENSE.txt
}