summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael2018-08-22 23:03:38 -0300
committerMichael2018-08-22 23:03:38 -0300
commit285ff7e837a2bc68b62ead16c6aea9d95f65e90e (patch)
tree248b35d2d55e9a3676ea1ddd36aff4002ee5467a
parent0aa6715e6afdfc400073a0924c53aea060425661 (diff)
downloadaur-285ff7e837a2bc68b62ead16c6aea9d95f65e90e.tar.gz
some fixes and updates
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD35
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31c063a23da7..a3d55bb299ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libretro-mupen64plus-git
pkgdesc = libretro port of Mupen64 Plus
- pkgver = 633.6f80cbc
+ pkgver = 651.4ca2fa8
pkgrel = 1
url = https://github.com/libretro/mupen64plus-libretro
arch = i686
@@ -9,9 +9,7 @@ pkgbase = libretro-mupen64plus-git
arch = armv6h
arch = armv7h
groups = libretro
- license = custom
- license = GPL
- license = LGPL
+ license = GPL3
makedepends = git
depends = libretro-core-info
source = mupen64plus-libretro::git://github.com/libretro/mupen64plus-libretro.git
diff --git a/PKGBUILD b/PKGBUILD
index 7c353f037164..7a3e4988c708 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,16 @@
-# Maintainer: Tomasz Paś <kierek93@gmail.com>
+# Maintainer: Mike Polvere <mic.tjs@gmail.com>
pkgname=libretro-mupen64plus-git
+
_gitname=mupen64plus-libretro
-pkgver=633.6f80cbc
+_libname=mupen64plus_libretro
+
+pkgver=651.4ca2fa8
pkgrel=1
pkgdesc="libretro port of Mupen64 Plus"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="https://github.com/libretro/mupen64plus-libretro"
-license=('custom' 'GPL' 'LGPL')
+license=('GPL3')
depends=('libretro-core-info')
makedepends=('git')
source=("${_gitname}::git://github.com/libretro/${_gitname}.git")
@@ -16,23 +19,23 @@ groups=('libretro')
md5sums=('SKIP')
pkgver() {
- cd "${_gitname}"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
build() {
- cd "${_gitname}"
- if grep -q odroid /proc/cpuinfo ;then
- platform=odroid make WITH_DYNAREC=arm
- elif grep -q BCM /proc/cpuinfo ;then
- platform=rpi make WITH_DYNAREC=arm
- elif [ $CARCH == "i686" ];then
- make WITH_DYNAREC=x86
- else
- make WITH_DYNAREC=$CARCH
- fi
+ cd "${_gitname}"
+ if [ ! -z "$(grep -i 'odroid' /proc/cpuinfo 2>/dev/null)" ]; then
+ platform=odroid make WITH_DYNAREC=$CARCH
+ elif [[ "$CARCH" == arm || "$CARCH" == armv6h || "$CARCH" == armv7h ]]; then
+ platform=rpi make WITH_DYNAREC=$CARCH
+ elif [ $CARCH == "i686" ]; then
+ make WITH_DYNAREC=x86
+ elif [ $CARCH == "x86_64" ]; then
+ make WITH_DYNAREC=$CARCH
+ fi
}
package() {
- install -Dm644 "${_gitname}/mupen64plus_libretro.so" "${pkgdir}/usr/lib/libretro/libretro-mupen64plus.so"
+ install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
}