summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Schneider2016-07-18 16:30:23 +0000
committerThomas Schneider2016-07-18 16:30:23 +0000
commitf8fa918aa822d036c91fa5a570674f182c5b5ef9 (patch)
tree8e262fccb266b3fd8da954cd2bb768d698224333
parent4800a84d7e770c0aea9bf5532bb72a5e32b703ae (diff)
downloadaur-f8fa918aa822d036c91fa5a570674f182c5b5ef9.tar.gz
better arch check
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0038fe80c658..e32fe028095e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,12 +22,16 @@ pkgver() {
build() {
cd "${_gitname}"
- if [ $CARCH == "armv6h" ];then
- platform=rpi make WITH_DYNAREC=arm
+ odroid=$(grep -i 'odroid' /proc/cpuinfo)
+
+ if grep -q odroid /proc/cpuinfo ;then
+ platform=odroid make WITH_DYNAREC=arm
+ elif grep -q BCM /proc/cpuinfo ;then
+ platform=rpi make WITH_DYNAREC=arm
elif [ $CARCH == "i686" ];then
- make WITH_DYNAREC=x86
+ make WITH_DYNAREC=x86
else
- make WITH_DYNAREC=$CARCH
+ make WITH_DYNAREC=$CARCH
fi
}