summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2019-11-06 10:58:49 +0100
committerOliver Jaksch2019-11-06 10:58:49 +0100
commit7794616bacacebb885f0a6d5f43372d008ed5026 (patch)
tree54a473d54098576b26328f3514ab9a8c44c5c466
downloadaur-7794616bacacebb885f0a6d5f43372d008ed5026.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD39
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0213d8fdd9a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = libretro-neocd-git
+ pkgdesc = Neo Geo CD emulator for libretro
+ pkgver = 18.e85f773
+ pkgrel = 1
+ url = https://github.com/libretro/neocd_libretro
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ groups = libretro
+ license = LGPL3
+ makedepends = git
+ makedepends = cmake
+ depends = zlib
+ depends = glibc
+ depends = libretro-core-info
+ depends = flac
+ depends = libogg
+ depends = libvorbis
+ depends = zlib
+ source = git+https://github.com/libretro/neocd_libretro.git
+ sha256sums = SKIP
+
+pkgname = libretro-neocd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f4ac2d2e0f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
+
+pkgname=libretro-neocd-git
+pkgver=18.e85f773
+pkgrel=1
+pkgdesc="Neo Geo CD emulator for libretro"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url="https://github.com/libretro/neocd_libretro"
+license=('LGPL3')
+groups=('libretro')
+depends=('zlib' 'glibc' 'libretro-core-info' 'flac' 'libogg' 'libvorbis' 'zlib')
+makedepends=('git' 'cmake')
+
+_libname=neocd_libretro
+_gitname=neocd_libretro
+source=("git+https://github.com/libretro/${_gitname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "${_gitname}"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "${_gitname}"
+ make
+}
+
+package() {
+ install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+ install -Dm644 "${_gitname}/LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+ msg2 "\e[1;32mneocd requires a bunch of BIOS files placed in the libretro 'system' folder. \e[0m"
+ msg2 "\e[1;32mPlease have a look at https://github.com/libretro/neocd_libretro how to accomplish this. \e[0m"
+}