summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lebedev2020-03-28 05:24:34 +0300
committerEugene Lebedev2020-03-28 05:24:34 +0300
commit48603872b209a02bf06e0b18caa70daa4f40c02b (patch)
tree62a7f77f828b974de221a0616456de60660c4f74
downloadaur-48603872b209a02bf06e0b18caa70daa4f40c02b.tar.gz
Add libretro-pcsx2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caef05a3a8da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libretro-pcsx2
+ pkgdesc = Launch Sony PlayStation 2 games through PCSX2, directly from RetroArch.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/coldscientist/libretro-pcsx2-launcher
+ arch = x86_64
+ groups = libretro
+ license = MIT
+ depends = pcsx2
+ depends = libretro-core-info
+ source = libretro-pcsx2::https://github.com/coldscientist/libretro-pcsx2-launcher/archive/1.1.1.tar.gz
+ sha256sums = 223894a0342be428f21914e8398cbc95f5dc394fcef66c848ebbe414a1259bdd
+
+pkgname = libretro-pcsx2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1588164d6ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Eugene Lebedev <satanych13@gmail.com>
+
+pkgname=libretro-pcsx2
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Launch Sony PlayStation 2 games through PCSX2, directly from RetroArch."
+arch=('x86_64')
+url="https://github.com/coldscientist/libretro-pcsx2-launcher"
+license=('MIT')
+depends=('pcsx2' 'libretro-core-info')
+groups=('libretro')
+source=("libretro-pcsx2::https://github.com/coldscientist/libretro-pcsx2-launcher/archive/$pkgver.tar.gz")
+sha256sums=(223894a0342be428f21914e8398cbc95f5dc394fcef66c848ebbe414a1259bdd)
+_dir="libretro-pcsx2-launcher-$pkgver"
+
+build() {
+ cd $_dir
+ make
+}
+
+package() {
+ install -Dm644 $_dir/dolphin_launcher_libretro.so "${pkgdir}/usr/lib/libretro/pcsx2_launcher_libretro.so"
+ install -Dm644 $_dir/dolphin_launcher_libretro.info "${pkgdir}/usr/share/libretro/info/pcsx2_launcher_libretro.info"
+}
+