summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWouter Wijsman2020-10-10 01:57:09 +0200
committerWouter Wijsman2020-10-10 01:57:09 +0200
commit910de28edfc6a1e4aa192d16bfd9d8a86a7b69d3 (patch)
tree557f4edc0d142f2f70a02c0a4649356cded07819
downloadaur-910de28edfc6a1e4aa192d16bfd9d8a86a7b69d3.tar.gz
Initial release
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD114
-rw-r--r--libretro.cpp.patch10
3 files changed, 171 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..397befb1a190
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+pkgbase = libretro-ppsspp-gameros
+ pkgdesc = Sony PlayStation Portable core with all required assets
+ pkgver = 28196
+ pkgrel = 1
+ url = https://github.com/libretro/ppsspp
+ arch = x86_64
+ groups = libretro
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = libglvnd
+ makedepends = python
+ depends = gcc-libs
+ depends = glew
+ depends = glibc
+ depends = libgl
+ depends = libpng
+ depends = libretro-core-info
+ depends = libzip
+ depends = snappy
+ depends = zlib
+ conflicts = libretro-ppsspp
+ source = libretro-ppsspp::git+https://github.com/hrydgard/ppsspp.git#commit=f0ea814107e3c29fc3c961195765e9148fa97fdd
+ source = git+https://github.com/Kingcom/armips.git
+ source = git+https://github.com/discordapp/discord-rpc.git
+ source = git+https://github.com/hrydgard/ppsspp-ffmpeg.git
+ source = ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
+ source = git+https://github.com/hrydgard/ppsspp-lang.git
+ source = ppsspp-miniupnp::git+https://github.com/hrydgard/miniupnp.git
+ source = git+https://github.com/Tencent/rapidjson.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ source = armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git
+ source = libretro.cpp.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = libretro-ppsspp-gameros
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3db0e416c35a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,114 @@
+# Maintainer: Wouter Wijsman <wwijsman@live.nl>
+# Maintainer original package: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Duck Hunt <vaporeon@tfwno.gf>
+
+pkgname=libretro-ppsspp-gameros
+pkgver=28196
+pkgrel=1
+pkgdesc='Sony PlayStation Portable core with all required assets'
+arch=(x86_64)
+url=https://github.com/libretro/ppsspp
+license=(GPL2)
+groups=(libretro)
+depends=(
+ gcc-libs
+ glew
+ glibc
+ libgl
+ libpng
+ libretro-core-info
+ libzip
+ snappy
+ zlib
+)
+makedepends=(
+ cmake
+ git
+ libglvnd
+ python
+)
+conflicts=(
+ libretro-ppsspp
+)
+_commit=f0ea814107e3c29fc3c961195765e9148fa97fdd
+source=(
+ libretro-ppsspp::git+https://github.com/hrydgard/ppsspp.git#commit=${_commit}
+ git+https://github.com/Kingcom/armips.git
+ git+https://github.com/discordapp/discord-rpc.git
+ git+https://github.com/hrydgard/ppsspp-ffmpeg.git
+ ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
+ git+https://github.com/hrydgard/ppsspp-lang.git
+ ppsspp-miniupnp::git+https://github.com/hrydgard/miniupnp.git
+ git+https://github.com/Tencent/rapidjson.git
+ git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git
+ libretro.cpp.patch
+)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd libretro-ppsspp
+
+ git rev-list --count HEAD
+}
+
+prepare() {
+ cd libretro-ppsspp
+
+ patch -p1 libretro/libretro.cpp < ../libretro.cpp.patch
+
+ for submodule in ffmpeg assets/lang ext/glslang ext/miniupnp; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
+ git submodule update ${submodule}
+ done
+ for submodule in ext/{armips,discord-rpc,rapidjson,SPIRV-Cross}; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../${submodule#*/}
+ git submodule update ${submodule}
+ done
+
+ cd ext/armips
+
+ for submodule in ext/tinyformat; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../../../armips-${submodule#*/}
+ git submodule update ${submodule}
+ done
+}
+
+build() {
+ cmake -S libretro-ppsspp -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DOpenGL_GL_PREFERENCE=GLVND \
+ -DHEADLESS=OFF \
+ -DLIBRETRO=ON \
+ -DMOBILE_DEVICE=OFF \
+ -DSIMULATOR=OFF \
+ -DUNITTEST=OFF \
+ -DUSE_SYSTEM_LIBZIP=ON \
+ -DUSE_SYSTEM_SNAPPY=ON \
+ -DUSING_QT_UI=OFF
+ make -C build
+}
+
+package() {
+ install -Dm 644 build/lib/ppsspp_libretro.so -t "${pkgdir}"/usr/lib/libretro/
+ install -Dm 644 libretro-ppsspp/LICENSE.TXT -t "${pkgdir}"/usr/share/licenses/libretro-ppsspp-git/
+
+ mkdir -p "${pkgdir}"/usr/share/libretro/bios/ppsspp/
+ cp -r build/assets "${pkgdir}"/usr/share/libretro/bios/ppsspp/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/libretro.cpp.patch b/libretro.cpp.patch
new file mode 100644
index 000000000000..34e82321cde6
--- /dev/null
+++ b/libretro.cpp.patch
@@ -0,0 +1,10 @@
+--- libretro/libretro.cpp.orig 2020-10-08 22:13:25.641893000 +0200
++++ libretro/libretro.cpp 2020-10-10 01:21:00.000136872 +0200
+@@ -601,6 +601,7 @@
+ g_Config.internalDataDirectory = retro_base_dir;
+
+ VFSRegister("", new DirectoryAssetReader(retro_base_dir.c_str()));
++ VFSRegister("", new DirectoryAssetReader("/usr/share/libretro/bios/ppsspp/assets/"));
+
+ coreState = CORE_POWERUP;
+ ctx = LibretroGraphicsContext::CreateGraphicsContext();