summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-08-08 17:28:39 -0700
committerJohn ShaggyTwoDope Jenkins2015-08-08 17:28:39 -0700
commit071e96b87d445615631982e089ec06e94f846441 (patch)
tree4a4e1773f6abcf5121c8ddbdb18f7b2280ba62ac
downloadaur-071e96b87d445615631982e089ec06e94f846441.tar.gz
init
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD62
2 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..634802f736e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = libretro-ppsspp-git
+ pkgdesc = libretro implementation of PPSSPP. (PlayStation Portable/PSP)
+ pkgver = 14111.67abe46
+ pkgrel = 1
+ url = https://github.com/libretro/ppsspp
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ license = GPL
+ makedepends = git
+ depends = zlib
+ depends = libgl
+ source = git+https://github.com/libretro/libretro-ppsspp.git
+ source = git+https://github.com/hrydgard/minidx9.git
+ source = git+https://github.com/libretro/ppsspp-ffmpeg
+ source = git+https://github.com/hrydgard/ppsspp-lang
+ source = git+https://github.com/libretro/ppsspp-native
+ source = git+https://github.com/hrydgard/pspautotests
+ source = git+https://github.com/hrydgard/ppsspp-redist
+ source = https://raw.github.com/libretro/libretro-super/master/dist/info/ppsspp_libretro.info
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = libretro-ppsspp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe6c34f329ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer : Johnathan Jenkins <twodopeshaggy@gmail.com>
+# Contributor: prettyvanilla <prettyvanilla@posteo.at>
+
+pkgname=libretro-ppsspp-git
+pkgver=14111.67abe46
+pkgrel=1
+pkgdesc="libretro implementation of PPSSPP. (PlayStation Portable/PSP)"
+arch=('i686' 'x86_64' 'arm' 'armv6h')
+url="https://github.com/libretro/ppsspp"
+license=('GPL')
+depends=('zlib' 'libgl')
+makedepends=('git')
+
+_gitname=libretro-ppsspp
+source=("git+https://github.com/libretro/${_gitname}.git"
+ "git+https://github.com/hrydgard/minidx9.git"
+ "git+https://github.com/libretro/ppsspp-ffmpeg"
+ "git+https://github.com/hrydgard/ppsspp-lang"
+ "git+https://github.com/libretro/ppsspp-native"
+ "git+https://github.com/hrydgard/pspautotests"
+ "git+https://github.com/hrydgard/ppsspp-redist"
+ "https://raw.github.com/libretro/libretro-super/master/dist/info/ppsspp_libretro.info"
+ )
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ )
+
+pkgver() {
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "${_gitname}"
+
+ git submodule init
+
+ git config submodule.dx9sdk.url "${srcdir}/minidx9"
+ git config submodule.ffmpeg.url "${srcdir}/ppsspp-ffmpeg"
+ git config submodule.lang.url "${srcdir}/ppsspp-lang"
+ git config submodule.native.url "${srcdir}/ppsspp-native"
+ git config submodule.pspautotests.url "${srcdir}/pspautotests"
+ git config submodule.redist.url "${srcdir}/ppsspp-redist"
+
+ git submodule update
+}
+
+build() {
+ cd "${_gitname}/libretro"
+ make
+}
+
+package() {
+ install -Dm644 "${_gitname}/libretro/ppsspp_libretro.so" "${pkgdir}/usr/lib/libretro/libretro-ppsspp.so"
+ install -Dm644 "ppsspp_libretro.info" "${pkgdir}/usr/lib/libretro/libretro-ppsspp.info"
+}