summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-10-16 00:38:12 +0200
committerAlexandre Bouvier2021-10-16 00:38:12 +0200
commit377ce94fd90af8f30ef038194a6d8098d8e042f1 (patch)
tree46af143c6226259b06b12178500eb02430c2f79a
parent0f8e8f1bf27a77496acdd0527e8bcf591b3b5fa3 (diff)
downloadaur-377ce94fd90af8f30ef038194a6d8098d8e042f1.tar.gz
update to 1.12.2.r9.g11b65ca22
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD141
2 files changed, 92 insertions, 99 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3499c3eea237..d5e85925026a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,42 +1,36 @@
pkgbase = libretro-ppsspp-git
pkgdesc = Sony PlayStation Portable core
- pkgver = r26710.7b4ddb426
+ pkgver = 1.12.2.r9.g11b65ca22
pkgrel = 1
- url = https://github.com/libretro/ppsspp
+ url = https://www.ppsspp.org/
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = i686
arch = x86_64
- groups = libretro-unstable
+ groups = libretro
license = GPL2
makedepends = cmake
makedepends = git
- makedepends = glu
- makedepends = libglvnd
- depends = gcc-libs
+ makedepends = libpng
+ makedepends = libzip
+ makedepends = ninja
+ makedepends = sdl2
+ makedepends = spirv-cross
+ makedepends = zstd
+ depends = ffmpeg
depends = glew
- depends = glibc
- depends = libgl
+ depends = glslang
depends = libretro-core-info
- depends = sdl2
- depends = zlib
+ depends = snappy
+ optdepends = ppsspp-assets
provides = libretro-ppsspp
conflicts = libretro-ppsspp
- source = libretro-ppsspp::git+https://github.com/libretro/ppsspp.git
+ source = git+https://github.com/hrydgard/ppsspp.git
source = git+https://github.com/Kingcom/armips.git
- source = git+https://github.com/discordapp/discord-rpc.git
- source = ppsspp-ffmpeg::git+https://github.com/hrydgard/ppsspp-ffmpeg.git
- source = ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
- source = git+https://github.com/hrydgard/ppsspp-lang.git
- source = git+https://github.com/Tencent/rapidjson.git
- source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
- source = armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = git+https://github.com/miniupnp/miniupnp.git
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = libretro-ppsspp-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0d4d4d4b4ca6..696b04dcc412 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,88 +1,87 @@
-# Maintainer: Daniel Menelkir <menelkir@itroll.org>
-# Old Maintainer: Maxime Gauduin <alucryd@archlinux.org>
-# Contributor: Oliver Jaksch <arch-aur@com-in.de>
-# Contributor: Duck Hunt <vaporeon@tfwno.gf>
-
-pkgname=libretro-ppsspp-git
-pkgver=r26710.7b4ddb426
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+_pkgname=libretro-ppsspp
+pkgname=$_pkgname-git
+pkgver=1.12.2.r9.g11b65ca22
pkgrel=1
-pkgdesc='Sony PlayStation Portable core'
-arch=('x86_64')
-url='https://github.com/libretro/ppsspp'
+pkgdesc="Sony PlayStation Portable core"
+arch=('arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
+url="https://www.ppsspp.org/"
license=('GPL2')
-groups=('libretro-unstable')
-depends=('gcc-libs' 'glew' 'glibc' 'libgl' 'libretro-core-info' 'sdl2' 'zlib')
-makedepends=('cmake' 'git' 'glu' 'libglvnd')
-provides=('libretro-ppsspp')
-conflicts=('libretro-ppsspp')
-source=('libretro-ppsspp::git+https://github.com/libretro/ppsspp.git'
- 'git+https://github.com/Kingcom/armips.git'
- 'git+https://github.com/discordapp/discord-rpc.git'
- 'ppsspp-ffmpeg::git+https://github.com/hrydgard/ppsspp-ffmpeg.git'
- 'ppsspp-glslang::git+https://github.com/hrydgard/glslang.git'
- 'git+https://github.com/hrydgard/ppsspp-lang.git'
- 'git+https://github.com/Tencent/rapidjson.git'
- 'git+https://github.com/KhronosGroup/SPIRV-Cross.git'
- 'armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git')
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+groups=('libretro')
+depends=(
+ 'ffmpeg'
+ 'glew'
+ 'glslang'
+ 'libretro-core-info'
+ 'snappy'
+)
+makedepends=(
+ 'cmake'
+ 'git'
+ 'libpng'
+ 'libzip'
+ 'ninja'
+ 'sdl2'
+ 'spirv-cross'
+ 'zstd'
+)
+optdepends=('ppsspp-assets')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=(
+ 'git+https://github.com/hrydgard/ppsspp.git'
+ 'git+https://github.com/Kingcom/armips.git'
+ 'git+https://github.com/miniupnp/miniupnp.git'
+)
+b2sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
- cd libretro-ppsspp
-
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ cd ppsspp
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
-
- cd libretro-ppsspp
+ cd ppsspp
+ git submodule init ext/{armips,miniupnp}
+ git config submodule.ext/armips.url ../armips
+ git config submodule.ext/miniupnp.url ../miniupnp
+ git submodule update
- for submodule in ffmpeg assets/lang ext/glslang; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
- git submodule update ${submodule}
- done
- for submodule in ext/{armips,discord-rpc,rapidjson,SPIRV-Cross}; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url ../${submodule#*/}
- git submodule update ${submodule}
- done
+ # unbundle glslang
+ rmdir ext/glslang
+ ln -s /usr/include/glslang ext/glslang
+ sed -i '/glslang/d' ext/CMakeLists.txt
- cd ext/armips
+ # unbundle spirv-cross
+ rmdir ext/SPIRV-Cross
+ ln -s /usr/include/spirv_cross ext/SPIRV-Cross
+ sed -i 's/spirv-cross-glsl/& spirv-cross-core/' CMakeLists.txt
+ sed -i '/SPIRV-Cross-build/d' ext/CMakeLists.txt
- for submodule in ext/tinyformat; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url ../../../armips-${submodule#*/}
- git submodule update ${submodule}
- done
+ # unbundle zstd
+ sed -i 's/libzstd_static/zstd/' CMakeLists.txt
+ sed -i '/zstd/d' ext/CMakeLists.txt
}
build() {
- cd build
-
- cmake ../libretro-ppsspp \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DHEADLESS='OFF' \
- -DLIBRETRO='ON' \
- -DUSING_QT_UI='OFF'
- make
+ cmake -S ppsspp -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DLIBRETRO=ON \
+ -DUSE_SYSTEM_FFMPEG=ON \
+ -DUSE_SYSTEM_LIBPNG=ON \
+ -DUSE_SYSTEM_LIBSDL2=ON \
+ -DUSE_SYSTEM_LIBZIP=ON \
+ -DUSE_SYSTEM_SNAPPY=ON \
+ -Wno-dev
+ cmake --build build
}
package() {
- install -Dm 644 build/lib/ppsspp_libretro.so -t "${pkgdir}"/usr/lib/libretro/
- install -Dm 644 libretro-ppsspp/LICENSE.TXT -t "${pkgdir}"/usr/share/licenses/libretro-ppsspp-git/
+ # shellcheck disable=SC2154
+ install -Dm644 -t "$pkgdir"/usr/lib/libretro build/lib/ppsspp_libretro.so
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname ppsspp/LICENSE.TXT
}
-
-# vim: ts=2 sw=2 et: