summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-03-28 11:52:44 +0200
committerMaxime Gauduin2018-03-28 11:53:51 +0200
commit5fe156408eaaff005e679f7a656a65451e498471 (patch)
treeb250c0ed6318adf9401c69fc698ac1954f0bcf21
parentff56750084e717accce93019b7caa9faf2d50177 (diff)
downloadaur-5fe156408eaaff005e679f7a656a65451e498471.tar.gz
Update libretro-ppsspp-git
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD89
2 files changed, 97 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c09c1fcc30a3..215eb09d040c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,38 @@
# Generated by mksrcinfo v8
-# Sat Mar 17 12:15:19 UTC 2018
+# Wed Mar 28 09:52:43 UTC 2018
pkgbase = libretro-ppsspp-git
- pkgdesc = libretro implementation of PPSSPP (PlayStation Portable/PSP)
- pkgver = 23821.dbbe316c5
+ pkgdesc = Sony PlayStation Portable core
+ pkgver = r24058.29de4b5a1
pkgrel = 1
- url = https://github.com/libretro/ppsspp
- arch = i686
+ url = https://github.com/libretro/libretro-ppsspp
arch = x86_64
- arch = arm
- arch = armv6h
- arch = armv7h
- groups = libretro
- license = GPL
+ groups = libretro-unstable
+ license = GPL2
+ makedepends = cmake
makedepends = git
- depends = zlib
- depends = libgl
+ makedepends = glu
+ depends = gcc-libs
+ depends = glew
depends = glibc
+ depends = libgl
depends = libretro-core-info
- source = git+https://github.com/libretro/ppsspp.git
+ depends = sdl2
+ depends = zlib
+ provides = libretro-ppsspp
+ conflicts = libretro-ppsspp
+ source = libretro-ppsspp::git+https://github.com/libretro/ppsspp.git
+ source = ppsspp-ffmpeg::git+https://github.com/hrydgard/ppsspp-ffmpeg.git
+ source = ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
+ source = git+https://github.com/hrydgard/ppsspp-lang.git
+ source = git+https://github.com/Kingcom/armips.git
+ source = armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = libretro-ppsspp-git
diff --git a/PKGBUILD b/PKGBUILD
index 80cd26d4b727..5c5d1723a95d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,85 @@
-# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Oliver Jaksch <arch-aur@com-in.de>
+# Contributor: Duck Hunt <vaporeon@tfwno.gf>
pkgname=libretro-ppsspp-git
-pkgver=23821.dbbe316c5
+pkgver=r24058.29de4b5a1
pkgrel=1
-pkgdesc="libretro implementation of PPSSPP (PlayStation Portable/PSP)"
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-url="https://github.com/libretro/ppsspp"
-license=('GPL')
-groups=('libretro')
-depends=('zlib' 'libgl' 'glibc' 'libretro-core-info')
-makedepends=('git')
-
-_libname=ppsspp_libretro
-_gitname=ppsspp
-source=("git+https://github.com/libretro/${_gitname}.git")
-sha256sums=('SKIP')
+pkgdesc='Sony PlayStation Portable core'
+arch=('x86_64')
+url='https://github.com/libretro/libretro-ppsspp'
+license=('GPL2')
+groups=('libretro-unstable')
+depends=('gcc-libs' 'glew' 'glibc' 'libgl' 'libretro-core-info' 'sdl2' 'zlib')
+makedepends=('cmake' 'git' 'glu')
+provides=('libretro-ppsspp')
+conflicts=('libretro-ppsspp')
+source=('libretro-ppsspp::git+https://github.com/libretro/ppsspp.git'
+ 'ppsspp-ffmpeg::git+https://github.com/hrydgard/ppsspp-ffmpeg.git'
+ 'ppsspp-glslang::git+https://github.com/hrydgard/glslang.git'
+ 'git+https://github.com/hrydgard/ppsspp-lang.git'
+ 'git+https://github.com/Kingcom/armips.git'
+ 'armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git'
+ 'git+https://github.com/KhronosGroup/SPIRV-Cross.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "${_gitname}"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd libretro-ppsspp
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${_gitname}"
- git submodule update --init --recursive
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+
+ cd libretro-ppsspp
+
+ for submodule in ffmpeg assets/lang ext/glslang; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
+ git submodule update ${submodule}
+ done
+ for submodule in ext/{SPIRV-Cross,armips}; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../${submodule#*/}
+ git submodule update ${submodule}
+ done
+
+ cd ext/armips
+
+ for submodule in ext/tinyformat; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../../../armips-${submodule#*/}
+ git submodule update ${submodule}
+ done
}
build() {
- cd "${_gitname}/libretro"
+ cd build
+
+ cmake ../libretro-ppsspp \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DHEADLESS='OFF' \
+ -DLIBRETRO='ON' \
+ -DUSING_QT_UI='OFF'
make
}
package() {
- install -Dm644 "${_gitname}/libretro/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+ cd build
+
+ install -Dm 644 lib/ppsspp_libretro.so -t "${pkgdir}"/usr/lib/libretro/
+ install -Dm 644 ../libretro-ppsspp/LICENSE.TXT -t "${pkgdir}"/usr/share/licenses/libretro-ppsspp-git/
}
+
+# vim: ts=2 sw=2 et: