summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-09-29 13:16:22 +0200
committerAlexandre Bouvier2023-09-29 13:16:22 +0200
commit620b85d8f72c32e214bec0225e18ca8464d030ce (patch)
treeab61003b0fca63270d769938a388813f37872f20
parentf60441bf9171a26afa1d14ebeec0a4e91e7df525 (diff)
downloadaur-620b85d8f72c32e214bec0225e18ca8464d030ce.tar.gz
unbundle
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b08a1c73e552..ddbc91b5c180 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libretro-ppsspp-git
pkgdesc = Sony PlayStation Portable core
pkgver = 1.16.5.r34.gdea038a91b
- pkgrel = 1
+ pkgrel = 2
url = https://www.ppsspp.org/
arch = aarch64
arch = armv7h
@@ -15,18 +15,19 @@ pkgbase = libretro-ppsspp-git
makedepends = ffmpeg4.4
makedepends = git
makedepends = glew
+ makedepends = libchdr
makedepends = libgl
+ makedepends = libpng
makedepends = libzip
makedepends = miniupnpc
makedepends = python
makedepends = rapidjson
+ makedepends = zlib
makedepends = zstd
depends = gcc-libs
depends = glibc
- depends = libpng
depends = libretro-core-info
depends = snappy
- depends = zlib
optdepends = ppsspp-assets
provides = libretro-ppsspp
conflicts = libretro-ppsspp
@@ -34,7 +35,6 @@ pkgbase = libretro-ppsspp-git
source = armips::git+https://github.com/Kingcom/armips.git
source = cpu_features::git+https://github.com/google/cpu_features.git
source = glslang::git+https://github.com/KhronosGroup/glslang.git
- source = libchdr::git+https://github.com/rtissera/libchdr.git
source = rcheevos::git+https://github.com/RetroAchievements/rcheevos.git
source = spirv-cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git
b2sums = SKIP
@@ -43,22 +43,22 @@ pkgbase = libretro-ppsspp-git
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
- b2sums = SKIP
pkgname = libretro-ppsspp-git
depends = gcc-libs
depends = glibc
- depends = libpng
depends = libretro-core-info
depends = snappy
- depends = zlib
depends = libavcodec.so
depends = libavformat.so
depends = libavutil.so
+ depends = libchdr.so
depends = libGLEW.so
depends = libminiupnpc.so
depends = libOpenGL.so
+ depends = libpng16.so
depends = libswresample.so
depends = libswscale.so
depends = libzip.so
+ depends = libz.so
depends = libzstd.so
diff --git a/PKGBUILD b/PKGBUILD
index 76a5f21ce902..9d1b9b896c89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=libretro-ppsspp
pkgname=$_pkgname-git
pkgver=1.16.5.r34.gdea038a91b
-pkgrel=1
+pkgrel=2
pkgdesc="Sony PlayStation Portable core"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://www.ppsspp.org/"
@@ -11,21 +11,22 @@ groups=('libretro')
depends=(
'gcc-libs'
'glibc'
- 'libpng'
'libretro-core-info'
'snappy'
- 'zlib'
)
makedepends=(
'cmake'
'ffmpeg4.4' # https://github.com/hrydgard/ppsspp/issues/15308
'git'
'glew'
+ 'libchdr'
'libgl'
+ 'libpng'
'libzip'
'miniupnpc'
'python'
'rapidjson'
+ 'zlib'
'zstd'
)
optdepends=('ppsspp-assets')
@@ -36,7 +37,6 @@ source=(
'armips::git+https://github.com/Kingcom/armips.git'
'cpu_features::git+https://github.com/google/cpu_features.git'
'glslang::git+https://github.com/KhronosGroup/glslang.git'
- 'libchdr::git+https://github.com/rtissera/libchdr.git'
'rcheevos::git+https://github.com/RetroAchievements/rcheevos.git'
'spirv-cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git'
)
@@ -47,7 +47,6 @@ b2sums=(
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
)
pkgver() {
@@ -60,11 +59,11 @@ prepare() {
git config submodule.cpu_features.url ../cpu_features
git config submodule.ext/armips.url ../armips
git config submodule.ext/glslang.url ../glslang
- git config submodule.ext/libchdr.url ../libchdr
git config submodule.ext/rcheevos.url ../rcheevos
git config submodule.ext/SPIRV-Cross.url ../spirv-cross
git -c protocol.file.allow=always submodule update
sed -i 's/ext\/rapidjson\/include\/\(rapidjson\/document\.h\)/\1/' Core/RetroAchievements.cpp
+ sed -i '/libchdr/d' ext/CMakeLists.txt
}
build() {
@@ -90,12 +89,15 @@ package() {
'libavcodec.so'
'libavformat.so'
'libavutil.so'
+ 'libchdr.so'
'libGLEW.so'
'libminiupnpc.so'
'libOpenGL.so'
+ 'libpng16.so'
'libswresample.so'
'libswscale.so'
'libzip.so'
+ 'libz.so'
'libzstd.so'
)
# shellcheck disable=SC2154