summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-12-05 05:45:28 +0100
committerAlexandre Bouvier2021-12-05 05:45:28 +0100
commit6e07c95a7c31011f2c25ea7b7663b357f6b25be5 (patch)
tree9dcadd349561dd4efa94cb9302a002e468192daf
parent988bfbe1b0b5300c6bb4ed040137363e2e5c6fd1 (diff)
downloadaur-6e07c95a7c31011f2c25ea7b7663b357f6b25be5.tar.gz
update to 1.12.3.r374.g4b5d703e0
* use system miniupnpc * use system zstd
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5e85925026a..8ce1ec89af76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libretro-ppsspp-git
pkgdesc = Sony PlayStation Portable core
- pkgver = 1.12.2.r9.g11b65ca22
+ pkgver = 1.12.3.r374.g4b5d703e0
pkgrel = 1
url = https://www.ppsspp.org/
arch = arm
@@ -14,6 +14,7 @@ pkgbase = libretro-ppsspp-git
makedepends = git
makedepends = libpng
makedepends = libzip
+ makedepends = miniupnpc
makedepends = ninja
makedepends = sdl2
makedepends = spirv-cross
@@ -28,8 +29,6 @@ pkgbase = libretro-ppsspp-git
conflicts = libretro-ppsspp
source = git+https://github.com/hrydgard/ppsspp.git
source = git+https://github.com/Kingcom/armips.git
- source = git+https://github.com/miniupnp/miniupnp.git
- b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a9cfc3e8b368..45c7c034da69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=libretro-ppsspp
pkgname=$_pkgname-git
-pkgver=1.12.2.r9.g11b65ca22
+pkgver=1.12.3.r374.g4b5d703e0
pkgrel=1
pkgdesc="Sony PlayStation Portable core"
arch=('arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
@@ -20,6 +20,7 @@ makedepends=(
'git'
'libpng'
'libzip'
+ 'miniupnpc'
'ninja'
'sdl2'
'spirv-cross'
@@ -31,12 +32,10 @@ conflicts=("$_pkgname")
source=(
'git+https://github.com/hrydgard/ppsspp.git'
'git+https://github.com/Kingcom/armips.git'
- 'git+https://github.com/miniupnp/miniupnp.git'
)
b2sums=(
'SKIP'
'SKIP'
- 'SKIP'
)
pkgver() {
@@ -46,22 +45,20 @@ pkgver() {
prepare() {
cd ppsspp
- git submodule init ext/{armips,miniupnp}
+ git submodule init ext/armips
git config submodule.ext/armips.url ../armips
- git config submodule.ext/miniupnp.url ../miniupnp
git submodule update
# unbundle glslang
rmdir ext/glslang
ln -s /usr/include/glslang ext/glslang
sed -i '/glslang/d' ext/CMakeLists.txt
+ # unbundle miniupnpc
+ sed -i 's|ext/miniupnp/||' Core/Util/PortManager.h
# unbundle spirv-cross
rmdir ext/SPIRV-Cross
ln -s /usr/include/spirv_cross ext/SPIRV-Cross
sed -i '/SPIRV-Cross-build/d' ext/CMakeLists.txt
sed -i 's/spirv-cross-glsl/& spirv-cross-core/' CMakeLists.txt
- # unbundle zstd
- sed -i '/zstd/d' ext/CMakeLists.txt
- sed -i 's/libzstd_static/zstd/' CMakeLists.txt
}
build() {
@@ -72,7 +69,9 @@ build() {
-DUSE_SYSTEM_LIBPNG=ON \
-DUSE_SYSTEM_LIBSDL2=ON \
-DUSE_SYSTEM_LIBZIP=ON \
+ -DUSE_SYSTEM_MINIUPNPC=ON \
-DUSE_SYSTEM_SNAPPY=ON \
+ -DUSE_SYSTEM_ZSTD=ON \
-Wno-dev
cmake --build build
}