summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-03-27 05:58:09 +0200
committerAlexandre Bouvier2023-03-27 05:58:09 +0200
commit95af69feb474f0c6eefa777d4199867e0146c3ca (patch)
tree4ad7cfb9b170097acdea61c2ca6d4f01644a565f
parent932ecb929a14cc6d03559cd80c071fec7db4f2a2 (diff)
downloadaur-95af69feb474f0c6eefa777d4199867e0146c3ca.tar.gz
update to 1.14.4.r1087.g668a6d63cb
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD50
2 files changed, 38 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bacb39a8fb5..20f5f351cc8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libretro-ppsspp-git
pkgdesc = Sony PlayStation Portable core
- pkgver = 1.13.1.r720.gb73958296
+ pkgver = 1.14.4.r1087.g668a6d63cb
pkgrel = 1
url = https://www.ppsspp.org/
arch = aarch64
@@ -13,21 +13,30 @@ pkgbase = libretro-ppsspp-git
license = GPL2
makedepends = cmake
makedepends = git
- makedepends = libpng
- makedepends = libzip
- makedepends = spirv-cross
- makedepends = zstd
+ makedepends = python
depends = ffmpeg4.4
+ depends = gcc-libs
depends = glew
- depends = glslang
+ depends = glibc
+ depends = libgl
+ depends = libpng
depends = libretro-core-info
+ depends = libzip
depends = miniupnpc
depends = snappy
+ depends = zlib
+ depends = zstd
optdepends = ppsspp-assets
provides = libretro-ppsspp
conflicts = libretro-ppsspp
source = ppsspp::git+https://github.com/hrydgard/ppsspp.git
source = armips::git+https://github.com/Kingcom/armips.git
+ source = cpu_features::git+https://github.com/google/cpu_features.git
+ source = glslang::git+https://github.com/KhronosGroup/glslang.git
+ source = SPIRV-Cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c14f6d2acf57..4bb25f7433ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
-_reponame=ppsspp
-_pkgname=libretro-$_reponame
+_pkgname=libretro-ppsspp
pkgname=$_pkgname-git
-pkgver=1.13.1.r720.gb73958296
+pkgver=1.14.4.r1087.g668a6d63cb
pkgrel=1
pkgdesc="Sony PlayStation Portable core"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
@@ -11,63 +10,61 @@ license=('GPL2')
groups=('libretro')
depends=(
'ffmpeg4.4' # https://github.com/hrydgard/ppsspp/issues/15308
+ 'gcc-libs'
'glew'
- 'glslang'
+ 'glibc'
+ 'libgl'
+ 'libpng'
'libretro-core-info'
+ 'libzip'
'miniupnpc'
'snappy'
-)
-makedepends=(
- 'cmake'
- 'git'
- 'libpng'
- 'libzip'
- 'spirv-cross'
+ 'zlib'
'zstd'
)
+makedepends=('cmake' 'git' 'python')
optdepends=('ppsspp-assets')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=(
- "$_reponame::git+https://github.com/hrydgard/ppsspp.git"
+ 'ppsspp::git+https://github.com/hrydgard/ppsspp.git'
'armips::git+https://github.com/Kingcom/armips.git'
+ 'cpu_features::git+https://github.com/google/cpu_features.git'
+ 'glslang::git+https://github.com/KhronosGroup/glslang.git'
+ 'SPIRV-Cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git'
)
b2sums=(
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
pkgver() {
- cd $_reponame
+ cd ppsspp
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd $_reponame
+ cd ppsspp
+ git config submodule.cpu_features.url ../cpu_features
git config submodule.ext/armips.url ../armips
+ git config submodule.ext/glslang.url ../glslang
+ git config submodule.ext/SPIRV-Cross.url ../SPIRV-Cross
git -c protocol.file.allow=always submodule update
- sed -i '/COMPILE_FLAGS/s/-O2//;/FLAGS_RELEASE/s/-O2//' CMakeLists.txt
- # unbundle glslang
- rmdir ext/glslang
- ln -s /usr/include/glslang ext/glslang
- sed -i '/glslang/d' ext/CMakeLists.txt
- # unbundle spirv-cross
- rmdir ext/SPIRV-Cross
- ln -s /usr/include/spirv_cross ext/SPIRV-Cross
- sed -i '/SPIRV-Cross-build/d' ext/CMakeLists.txt
- sed -i 's/spirv-cross-glsl/& spirv-cross-core/' CMakeLists.txt
}
build() {
export PKG_CONFIG_PATH=/usr/lib/ffmpeg4.4/pkgconfig
- cmake -S $_reponame -B build \
+ cmake -S ppsspp -B build \
+ -DARMIPS_USE_STD_FILESYSTEM=ON \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
-DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
-DCMAKE_SKIP_RPATH=ON \
-DLIBRETRO=ON \
-DUSE_SYSTEM_FFMPEG=ON \
- -DUSE_SYSTEM_LIBPNG=ON \
-DUSE_SYSTEM_LIBZIP=ON \
-DUSE_SYSTEM_MINIUPNPC=ON \
-DUSE_SYSTEM_SNAPPY=ON \
@@ -79,5 +76,4 @@ build() {
package() {
# shellcheck disable=SC2154
install -Dm644 -t "$pkgdir"/usr/lib/libretro build/lib/ppsspp_libretro.so
- install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname $_reponame/LICENSE.TXT
}