summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2017-09-03 05:36:45 +0200
committerOliver Jaksch2017-09-03 05:36:45 +0200
commitb4ec22013f79b046e028e4b039069da18745405a (patch)
treef23737b4c6232017c96fe38b5729ced59262a264
parentb0df184a065dfad7faf0616805ee254914db0bf9 (diff)
downloadaur-b4ec22013f79b046e028e4b039069da18745405a.tar.gz
Complete rework
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 12 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5de74b334c39..2f2924107551 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Jan 27 07:16:19 UTC 2017
+# Sun Sep 3 03:36:44 UTC 2017
pkgbase = libretro-ppsspp-git
pkgdesc = libretro implementation of PPSSPP (PlayStation Portable/PSP)
- pkgver = 17177.5f7bcf7bf
- pkgrel = 2
- url = https://github.com/libretro/libretro-ppsspp
+ pkgver = 22728.2a9312fec
+ pkgrel = 1
+ url = https://github.com/libretro/ppsspp
arch = i686
arch = x86_64
arch = arm
@@ -15,22 +15,10 @@ pkgbase = libretro-ppsspp-git
makedepends = git
depends = zlib
depends = libgl
- source = git+https://github.com/libretro/libretro-ppsspp.git
- source = git+https://github.com/hrydgard/minidx9.git
- source = git+https://github.com/libretro/ppsspp-ffmpeg
- source = git+https://github.com/hrydgard/ppsspp-lang
- source = git+https://github.com/libretro/ppsspp-native
- source = git+https://github.com/hrydgard/pspautotests
- source = git+https://github.com/hrydgard/ppsspp-redist
+ source = git+https://github.com/libretro/ppsspp.git
source = https://raw.github.com/libretro/libretro-super/master/dist/info/ppsspp_libretro.info
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
pkgname = libretro-ppsspp-git
diff --git a/PKGBUILD b/PKGBUILD
index 1b7dd5d71353..c82608c475a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,22 @@
# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
pkgname=libretro-ppsspp-git
-pkgver=17177.5f7bcf7bf
-pkgrel=2
+pkgver=22728.2a9312fec
+pkgrel=1
pkgdesc="libretro implementation of PPSSPP (PlayStation Portable/PSP)"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-url="https://github.com/libretro/libretro-ppsspp"
+url="https://github.com/libretro/ppsspp"
license=('GPL')
groups=('libretro')
depends=('zlib' 'libgl')
makedepends=('git')
_libname=ppsspp_libretro
-_gitname=libretro-ppsspp
+_gitname=ppsspp
source=("git+https://github.com/libretro/${_gitname}.git"
- "git+https://github.com/hrydgard/minidx9.git"
- "git+https://github.com/libretro/ppsspp-ffmpeg"
- "git+https://github.com/hrydgard/ppsspp-lang"
- "git+https://github.com/libretro/ppsspp-native"
- "git+https://github.com/hrydgard/pspautotests"
- "git+https://github.com/hrydgard/ppsspp-redist"
- "https://raw.github.com/libretro/libretro-super/master/dist/info/ppsspp_libretro.info"
- )
+ "https://raw.github.com/libretro/libretro-super/master/dist/info/ppsspp_libretro.info")
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- )
+ 'SKIP')
pkgver() {
cd "${_gitname}"
@@ -39,17 +25,7 @@ pkgver() {
prepare() {
cd "${_gitname}"
-
- git submodule init
-
- git config submodule.dx9sdk.url "${srcdir}/minidx9"
- git config submodule.ffmpeg.url "${srcdir}/ppsspp-ffmpeg"
- git config submodule.lang.url "${srcdir}/ppsspp-lang"
- git config submodule.native.url "${srcdir}/ppsspp-native"
- git config submodule.pspautotests.url "${srcdir}/pspautotests"
- git config submodule.redist.url "${srcdir}/ppsspp-redist"
-
- git submodule update
+ git submodule update --init --recursive
}
build() {