summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-08-03 18:28:54 +0200
committerAlexandre Bouvier2023-08-03 18:28:54 +0200
commite3f8cdc876c69ee4b24cec1d7ccc24456654b122 (patch)
tree4e8a877ce8fc691c1756b3ec8ecc0bf36f3cedf8
parentfc5979e386653112c412405b35039c85035beebf (diff)
downloadaur-e3f8cdc876c69ee4b24cec1d7ccc24456654b122.tar.gz
update to 1.15.4.r851.gdfabad8d29
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d215db931fa..b8e8483ed29f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libretro-ppsspp-git
pkgdesc = Sony PlayStation Portable core
- pkgver = 1.15.3.r54.g30b11e8ada
+ pkgver = 1.15.4.r851.gdfabad8d29
pkgrel = 1
url = https://www.ppsspp.org/
arch = aarch64
@@ -19,6 +19,7 @@ pkgbase = libretro-ppsspp-git
makedepends = libzip
makedepends = miniupnpc
makedepends = python
+ makedepends = rapidjson
makedepends = zstd
depends = gcc-libs
depends = glibc
@@ -33,7 +34,9 @@ pkgbase = libretro-ppsspp-git
source = armips::git+https://github.com/Kingcom/armips.git
source = cpu_features::git+https://github.com/google/cpu_features.git
source = glslang::git+https://github.com/KhronosGroup/glslang.git
- source = SPIRV-Cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ source = rcheevos::git+https://github.com/RetroAchievements/rcheevos.git
+ source = spirv-cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d219a75614da..7734626acae6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=libretro-ppsspp
pkgname=$_pkgname-git
-pkgver=1.15.3.r54.g30b11e8ada
+pkgver=1.15.4.r851.gdfabad8d29
pkgrel=1
pkgdesc="Sony PlayStation Portable core"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
@@ -25,6 +25,7 @@ makedepends=(
'libzip'
'miniupnpc'
'python'
+ 'rapidjson'
'zstd'
)
optdepends=('ppsspp-assets')
@@ -35,7 +36,8 @@ source=(
'armips::git+https://github.com/Kingcom/armips.git'
'cpu_features::git+https://github.com/google/cpu_features.git'
'glslang::git+https://github.com/KhronosGroup/glslang.git'
- 'SPIRV-Cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git'
+ 'rcheevos::git+https://github.com/RetroAchievements/rcheevos.git'
+ 'spirv-cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git'
)
b2sums=(
'SKIP'
@@ -43,6 +45,7 @@ b2sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
pkgver() {
@@ -55,8 +58,10 @@ prepare() {
git config submodule.cpu_features.url ../cpu_features
git config submodule.ext/armips.url ../armips
git config submodule.ext/glslang.url ../glslang
- git config submodule.ext/SPIRV-Cross.url ../SPIRV-Cross
+ git config submodule.ext/rcheevos.url ../rcheevos
+ git config submodule.ext/SPIRV-Cross.url ../spirv-cross
git -c protocol.file.allow=always submodule update
+ sed -i 's/ext\/rapidjson\/include\/\(rapidjson\/document\.h\)/\1/' Core/RetroAchievements.cpp
}
build() {