summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-04-08 09:24:35 +0200
committerAlexandre Bouvier2022-04-08 09:24:35 +0200
commitf0ec9c1e19bede48f00e4101d77f6c8440f17da7 (patch)
tree245a50560f22742768a7edd21d3f969ec363ddd0
parentc0db5e81cf813db15b5fb815c227968acd4826bf (diff)
downloadaur-f0ec9c1e19bede48f00e4101d77f6c8440f17da7.tar.gz
prettify
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6aa418c29bce..dbf69e729abe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,8 +26,8 @@ pkgbase = libretro-ppsspp-git
optdepends = ppsspp-assets
provides = libretro-ppsspp
conflicts = libretro-ppsspp
- source = git+https://github.com/hrydgard/ppsspp.git
- source = git+https://github.com/Kingcom/armips.git
+ source = ppsspp::git+https://github.com/hrydgard/ppsspp.git
+ source = armips::git+https://github.com/Kingcom/armips.git
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6d3c3231c567..4a75226f1df9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
-_pkgname=libretro-ppsspp
+_reponame=ppsspp
+_pkgname=libretro-$_reponame
pkgname=$_pkgname-git
pkgver=1.12.3.r980.g3bfab6326
pkgrel=2
@@ -28,8 +29,8 @@ optdepends=('ppsspp-assets')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=(
- 'git+https://github.com/hrydgard/ppsspp.git'
- 'git+https://github.com/Kingcom/armips.git'
+ "$_reponame::git+https://github.com/hrydgard/ppsspp.git"
+ 'armips::git+https://github.com/Kingcom/armips.git'
)
b2sums=(
'SKIP'
@@ -37,12 +38,12 @@ b2sums=(
)
pkgver() {
- cd ppsspp
+ cd $_reponame
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd ppsspp
+ cd $_reponame
git submodule init ext/armips
git config submodule.ext/armips.url ../armips
git submodule update
@@ -59,7 +60,7 @@ prepare() {
build() {
export PKG_CONFIG_PATH=/usr/lib/ffmpeg4.4/pkgconfig
- cmake -S ppsspp -B build \
+ cmake -S $_reponame -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_SKIP_RPATH=ON \
-DLIBRETRO=ON \
@@ -76,5 +77,5 @@ build() {
package() {
# shellcheck disable=SC2154
install -Dm644 -t "$pkgdir"/usr/lib/libretro build/lib/ppsspp_libretro.so
- install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname ppsspp/LICENSE.TXT
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname $_reponame/LICENSE.TXT
}