summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralucryd2021-05-07 07:18:47 +0000
committerDobroslaw Kijowski2021-08-13 22:02:35 +0200
commit663d9ed84dbed2308a42706b9c9eddb60abe9d0e (patch)
tree5475701c7e62a678af69d730cfa5cd0c750407b9
parentc0bfbcb0c01e2af9cdcab74278260334f8e84273 (diff)
downloadaur-663d9ed84dbed2308a42706b9c9eddb60abe9d0e.tar.gz
upgpkg: libretro-ppsspp 29742-1
git-svn-id: file:///srv/repos/svn-community/svn@928562 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--libretro-ppsspp-system-zstd.patch42
3 files changed, 62 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afe52c258479..4fe0ef10a914 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libretro-ppsspp-rbp
pkgdesc = Sony PlayStation Portable core (build for Raspberry Pi)
- pkgver = 29606
+ pkgver = 29742
pkgrel = 1
url = https://github.com/libretro/ppsspp
arch = armv7h
@@ -9,15 +9,17 @@ pkgbase = libretro-ppsspp-rbp
makedepends = cmake
makedepends = git
makedepends = mesa
+ makedepends = ninja
makedepends = python
depends = ffmpeg
depends = libegl
depends = libretro-core-info
depends = libzip
depends = snappy
- provides = libretro-ppsspp=29606
+ depends = zstd
+ provides = libretro-ppsspp=29742
conflicts = libretro-ppsspp
- source = libretro-ppsspp::git+https://github.com/hrydgard/ppsspp.git#commit=0328a0d550840687b55f45dddcc0838b2c670aeb
+ source = libretro-ppsspp::git+https://github.com/hrydgard/ppsspp.git#commit=4462b0c612986cfdd585885eb56098d19c2181ec
source = git+https://github.com/Kingcom/armips.git
source = git+https://github.com/discordapp/discord-rpc.git
source = ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
@@ -27,6 +29,7 @@ pkgbase = libretro-ppsspp-rbp
source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
source = armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git
source = libretro-ppsspp-assets-path.patch
+ source = libretro-ppsspp-system-zstd.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -37,5 +40,6 @@ pkgbase = libretro-ppsspp-rbp
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 2234ab0c53849ed728889305a68119a365da16094a1b7ac2c4d2a2ababe5c8f5
+ sha256sums = c65ae3f20976a573b1a74600b02515e3f665513864a49e10db57c2fd170819e7
pkgname = libretro-ppsspp-rbp
diff --git a/PKGBUILD b/PKGBUILD
index 4b5ee59c26b3..bd1c7dfa4ff7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=libretro-ppsspp
pkgname=libretro-ppsspp-rbp
-pkgver=29606
+pkgver=29742
pkgrel=1
pkgdesc='Sony PlayStation Portable core (build for Raspberry Pi)'
arch=(armv7h)
@@ -19,14 +19,16 @@ depends=(
libretro-core-info
libzip
snappy
+ zstd
)
makedepends=(
cmake
git
mesa
+ ninja
python
)
-_commit=0328a0d550840687b55f45dddcc0838b2c670aeb
+_commit=4462b0c612986cfdd585885eb56098d19c2181ec
source=(
libretro-ppsspp::git+https://github.com/hrydgard/ppsspp.git#commit=${_commit}
git+https://github.com/Kingcom/armips.git
@@ -38,6 +40,7 @@ source=(
git+https://github.com/KhronosGroup/SPIRV-Cross.git
armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git
libretro-ppsspp-assets-path.patch
+ libretro-ppsspp-system-zstd.patch
)
sha256sums=('SKIP'
'SKIP'
@@ -48,7 +51,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '2234ab0c53849ed728889305a68119a365da16094a1b7ac2c4d2a2ababe5c8f5')
+ '2234ab0c53849ed728889305a68119a365da16094a1b7ac2c4d2a2ababe5c8f5'
+ 'c65ae3f20976a573b1a74600b02515e3f665513864a49e10db57c2fd170819e7')
pkgver() {
cd libretro-ppsspp
@@ -60,13 +64,14 @@ prepare() {
cd libretro-ppsspp
patch -Np1 -i ../libretro-ppsspp-assets-path.patch
+ patch -Np1 -i ../libretro-ppsspp-system-zstd.patch
for submodule in assets/lang ext/glslang ext/miniupnp; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
git submodule update ${submodule}
done
- for submodule in ext/{armips,discord-rpc,rapidjson,SPIRV-Cross}; do
+ for submodule in ext/{armips,rapidjson,SPIRV-Cross}; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../${submodule#*/}
git submodule update ${submodule}
@@ -82,7 +87,7 @@ prepare() {
}
build() {
- cmake -S libretro-ppsspp -B build \
+ cmake -S libretro-ppsspp -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_SKIP_RPATH=ON \
-DUSING_GLES2=yes \
@@ -93,10 +98,12 @@ build() {
-DUNITTEST=OFF \
-DUSE_SYSTEM_LIBZIP=ON \
-DUSE_SYSTEM_SNAPPY=ON \
+ -DUSE_SYSTEM_ZSTD=ON \
-DUSING_QT_UI=OFF \
+ -Wno-dev \
-DUSE_FFMPEG=yes \
-DUSE_SYSTEM_FFMPEG=yes
- make -C build
+ cmake --build build
}
package() {
diff --git a/libretro-ppsspp-system-zstd.patch b/libretro-ppsspp-system-zstd.patch
new file mode 100644
index 000000000000..a89e64778e25
--- /dev/null
+++ b/libretro-ppsspp-system-zstd.patch
@@ -0,0 +1,42 @@
+diff '--color=auto' -rupN libretro-ppsspp.orig/CMakeLists.txt libretro-ppsspp/CMakeLists.txt
+--- libretro-ppsspp.orig/CMakeLists.txt 2021-05-07 09:02:42.107209058 +0200
++++ libretro-ppsspp/CMakeLists.txt 2021-05-07 09:10:24.353248166 +0200
+@@ -135,6 +135,7 @@ option(USE_MINIUPNPC "Build with miniUPn
+ option(USE_SYSTEM_SNAPPY "Dynamically link against system snappy" ${USE_SYSTEM_SNAPPY})
+ option(USE_SYSTEM_FFMPEG "Dynamically link against system FFMPEG" ${USE_SYSTEM_FFMPEG})
+ option(USE_SYSTEM_LIBZIP "Dynamically link against system libzip" ${USE_SYSTEM_LIBZIP})
++option(USE_SYSTEM_ZSTD "Dynamically link against system zstd" ${USE_SYSTEM_ZSTD})
+ option(USE_ASAN "Use address sanitizer" OFF)
+ option(USE_UBSAN "Use undefined behaviour sanitizer" OFF)
+
+@@ -1817,8 +1818,20 @@ if(ANDROID)
+ endif()
+ endif()
+
+-set(CoreExtraLibs ${CoreExtraLibs} armips libzstd_static)
+-include_directories(ext/zstd/lib)
++set(CoreExtraLibs ${CoreExtraLibs} armips)
++
++find_package(PkgConfig)
++if(PKG_CONFIG_FOUND)
++ pkg_check_modules(ZSTD libzstd)
++endif()
++if(ZSTD_FOUND AND USE_SYSTEM_ZSTD)
++ include_directories(${ZSTD_INCLUDE_DIRS})
++ target_link_libraries(${CoreLibName} ${ZSTD_LIBRARIES})
++else()
++ add_subdirectory(ext/zstd/build/cmake EXCLUDE_FROM_ALL)
++ include_directories(ext/zstd/lib)
++ set(CoreExtraLibs ${CoreExtraLibs} libzstd_static)
++endif()
+
+ # needed for VK_USE_PLATFORM_XCB_KHR only
+ #if(VULKAN AND NOT WIN32)
+diff '--color=auto' -rupN libretro-ppsspp.orig/ext/CMakeLists.txt libretro-ppsspp/ext/CMakeLists.txt
+--- libretro-ppsspp.orig/ext/CMakeLists.txt 2021-05-07 09:02:41.033776512 +0200
++++ libretro-ppsspp/ext/CMakeLists.txt 2021-05-07 09:11:00.643266519 +0200
+@@ -22,4 +22,3 @@ add_subdirectory(SPIRV-Cross-build)
+ if(USE_DISCORD AND NOT IOS AND NOT LIBRETRO)
+ add_subdirectory(discord-rpc-build)
+ endif()
+-add_subdirectory(zstd/build/cmake EXCLUDE_FROM_ALL)