summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDobroslaw Kijowski2020-04-02 13:02:40 +0200
committerdobo_pl2020-04-06 22:10:04 +0200
commit96985faaedbddb55c00ee5f2ad88e26e7149b595 (patch)
treeda2f92145d5fe2e1a258e4b73bcbe65915dca431
downloadaur-96985faaedbddb55c00ee5f2ad88e26e7149b595.tar.gz
Initial commit
* Import verion 26779 from ABS
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD96
2 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2aaf7a2421df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = libretro-ppsspp
+ pkgdesc = Sony PlayStation Portable core
+ pkgver = 26779
+ pkgrel = 1
+ url = https://github.com/libretro/ppsspp
+ arch = x86_64
+ groups = libretro
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = libglvnd
+ makedepends = mesa
+ makedepends = python
+ depends = glew
+ depends = libgl
+ depends = libretro-core-info
+ depends = zlib
+ source = libretro-ppsspp::git+https://github.com/hrydgard/ppsspp.git#commit=8e9926394933d8561a84564b8b26e30d07e19fdc
+ source = git+https://github.com/Kingcom/armips.git
+ source = git+https://github.com/discordapp/discord-rpc.git
+ source = git+https://github.com/hrydgard/ppsspp-ffmpeg.git
+ source = ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
+ source = git+https://github.com/hrydgard/ppsspp-lang.git
+ source = git+https://github.com/Tencent/rapidjson.git
+ source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ source = armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = libretro-ppsspp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3afaa5a7b37c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,96 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Duck Hunt <vaporeon@tfwno.gf>
+
+pkgname=libretro-ppsspp
+pkgver=26779
+pkgrel=1
+pkgdesc='Sony PlayStation Portable core'
+arch=(x86_64)
+url=https://github.com/libretro/ppsspp
+license=(GPL2)
+groups=(libretro)
+depends=(
+ glew
+ libgl
+ libretro-core-info
+ zlib
+)
+makedepends=(
+ cmake
+ git
+ libglvnd
+ mesa
+ python
+)
+source=(
+ libretro-ppsspp::git+https://github.com/hrydgard/ppsspp.git#commit=8e9926394933d8561a84564b8b26e30d07e19fdc
+ git+https://github.com/Kingcom/armips.git
+ git+https://github.com/discordapp/discord-rpc.git
+ git+https://github.com/hrydgard/ppsspp-ffmpeg.git
+ ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
+ git+https://github.com/hrydgard/ppsspp-lang.git
+ git+https://github.com/Tencent/rapidjson.git
+ git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ armips-tinyformat::git+https://github.com/Kingcom/tinyformat.git
+)
+sha256sums=(
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+ SKIP
+)
+
+pkgver() {
+ cd libretro-ppsspp
+
+ git rev-list --count HEAD
+}
+
+prepare() {
+ cd libretro-ppsspp
+
+ for submodule in ffmpeg assets/lang ext/glslang; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
+ git submodule update ${submodule}
+ done
+ for submodule in ext/{armips,discord-rpc,rapidjson,SPIRV-Cross}; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../${submodule#*/}
+ git submodule update ${submodule}
+ done
+
+ cd ext/armips
+
+ for submodule in ext/tinyformat; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../../../armips-${submodule#*/}
+ git submodule update ${submodule}
+ done
+}
+
+build() {
+ cmake -S libretro-ppsspp -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DOpenGL_GL_PREFERENCE=GLVND \
+ -DHEADLESS=OFF \
+ -DLIBRETRO=ON \
+ -DMOBILE_DEVICE=OFF \
+ -DSIMULATOR=OFF \
+ -DUNITTEST=OFF \
+ -DUSING_QT_UI=OFF
+ make -C build
+}
+
+package() {
+ install -Dm 644 build/lib/ppsspp_libretro.so -t "${pkgdir}"/usr/lib/libretro/
+ install -Dm 644 libretro-ppsspp/LICENSE.TXT -t "${pkgdir}"/usr/share/licenses/libretro-ppsspp-git/
+}
+
+# vim: ts=2 sw=2 et: