summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDobroslaw Kijowski2020-04-06 16:02:20 +0200
committerdobo_pl2020-04-06 22:10:45 +0200
commitfb7b72f1d55f67e672867cc2a6c33a6b354aa0a2 (patch)
treef47b470f81059090959f0d0b462f84cef9b7e6bd
parent96985faaedbddb55c00ee5f2ad88e26e7149b595 (diff)
downloadaur-fb7b72f1d55f67e672867cc2a6c33a6b354aa0a2.tar.gz
Make it work with Raspberry Pi
* Use system ffmpeg. Linking prebuilt ones fails because of PIC reasons. Recompiling them with --enabled-pic fixes linkage error but run-time fails with SIGEGV. * Use OpenGL ES 2.0.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2aaf7a2421df..71e7043c80e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
-pkgbase = libretro-ppsspp
- pkgdesc = Sony PlayStation Portable core
+pkgbase = libretro-ppsspp-rbp
+ pkgdesc = Sony PlayStation Portable core (build for Raspberry Pi)
pkgver = 26779
pkgrel = 1
url = https://github.com/libretro/ppsspp
- arch = x86_64
+ arch = armv7h
groups = libretro
license = GPL2
makedepends = cmake
makedepends = git
- makedepends = libglvnd
makedepends = mesa
makedepends = python
- depends = glew
- depends = libgl
+ depends = ffmpeg
+ depends = libegl
depends = libretro-core-info
- depends = zlib
+ provides = libretro-ppsspp=26779
+ conflicts = libretro-ppsspp
source = libretro-ppsspp::git+https://github.com/hrydgard/ppsspp.git#commit=8e9926394933d8561a84564b8b26e30d07e19fdc
source = git+https://github.com/Kingcom/armips.git
source = git+https://github.com/discordapp/discord-rpc.git
- source = git+https://github.com/hrydgard/ppsspp-ffmpeg.git
source = ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
source = git+https://github.com/hrydgard/ppsspp-lang.git
source = git+https://github.com/Tencent/rapidjson.git
@@ -32,7 +31,6 @@ pkgbase = libretro-ppsspp
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
-pkgname = libretro-ppsspp
+pkgname = libretro-ppsspp-rbp
diff --git a/PKGBUILD b/PKGBUILD
index 3afaa5a7b37c..f3cb67ae7b0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Maintainer: Dobroslaw Kijowski <dobo90_at_gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Duck Hunt <vaporeon@tfwno.gf>
-pkgname=libretro-ppsspp
+_pkgname=libretro-ppsspp
+pkgname=libretro-ppsspp-rbp
pkgver=26779
pkgrel=1
-pkgdesc='Sony PlayStation Portable core'
-arch=(x86_64)
+pkgdesc='Sony PlayStation Portable core (build for Raspberry Pi)'
+arch=(armv7h)
url=https://github.com/libretro/ppsspp
license=(GPL2)
groups=(libretro)
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
depends=(
- glew
- libgl
+ ffmpeg
+ libegl
libretro-core-info
- zlib
)
makedepends=(
cmake
git
- libglvnd
mesa
python
)
@@ -26,7 +28,6 @@ source=(
libretro-ppsspp::git+https://github.com/hrydgard/ppsspp.git#commit=8e9926394933d8561a84564b8b26e30d07e19fdc
git+https://github.com/Kingcom/armips.git
git+https://github.com/discordapp/discord-rpc.git
- git+https://github.com/hrydgard/ppsspp-ffmpeg.git
ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
git+https://github.com/hrydgard/ppsspp-lang.git
git+https://github.com/Tencent/rapidjson.git
@@ -42,7 +43,6 @@ sha256sums=(
SKIP
SKIP
SKIP
- SKIP
)
pkgver() {
@@ -54,7 +54,7 @@ pkgver() {
prepare() {
cd libretro-ppsspp
- for submodule in ffmpeg assets/lang ext/glslang; do
+ for submodule in assets/lang ext/glslang; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
git submodule update ${submodule}
@@ -78,13 +78,15 @@ build() {
cmake -S libretro-ppsspp -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_SKIP_RPATH=ON \
- -DOpenGL_GL_PREFERENCE=GLVND \
+ -DUSING_GLES2=yes \
-DHEADLESS=OFF \
-DLIBRETRO=ON \
-DMOBILE_DEVICE=OFF \
-DSIMULATOR=OFF \
-DUNITTEST=OFF \
- -DUSING_QT_UI=OFF
+ -DUSING_QT_UI=OFF \
+ -DUSE_FFMPEG=yes \
+ -DUSE_SYSTEM_FFMPEG=yes
make -C build
}