summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-06-09 21:04:59 +0200
committerAlexandre Bouvier2023-06-09 21:04:59 +0200
commit8e9e7c8d0240180d4b1cb3e07bd904719e145d5f (patch)
tree5c1c6bbfb364c427de87a258efeb7db009524b1d
parent245141fa7bb1bcab36247bd11be74ff5fc0e361e (diff)
downloadaur-8e9e7c8d0240180d4b1cb3e07bd904719e145d5f.tar.gz
update to r1257.755b4bb
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
2 files changed, 39 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce6b49a06fc0..4d597079119f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,26 @@
pkgbase = libretro-shaders-slang-git
pkgdesc = Collection of shaders for libretro
- pkgver = r370.b91c670
- pkgrel = 2
- url = https://www.libretro.com/
+ pkgver = r1257.755b4bb
+ pkgrel = 1
+ url = https://github.com/libretro/slang-shaders
arch = any
- groups = libretro-unstable
+ groups = libretro
+ license = BSD
+ license = CCPL
+ license = GPL2
license = GPL3
+ license = LGPL2.1
+ license = LGPL3
+ license = MIT
+ license = MPL2
+ license = Unlicense
makedepends = git
+ optdepends = retroarch
+ provides = libretro-shaders-slang=1257.755b4bb
provides = libretro-shaders
- provides = libretro-shaders-slang
conflicts = libretro-shaders-slang
+ options = !strip
source = libretro-shaders-slang::git+https://github.com/libretro/slang-shaders.git
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = libretro-shaders-slang-git
diff --git a/PKGBUILD b/PKGBUILD
index c3407211a243..427000a80a9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,29 @@
-# Maintainer : Anthony Wang <ta180m@pm.me>
-# Contributor : Maxime Gauduin <alucryd@archlinux.org>
-
-pkgname=libretro-shaders-slang-git
-pkgver=r370.b91c670
-pkgrel=2
-pkgdesc='Collection of shaders for libretro'
-arch=(any)
-url=https://www.libretro.com/
-license=(GPL3)
-groups=(libretro-unstable)
-provides=(
- libretro-shaders
- libretro-shaders-slang
-)
-conflicts=(libretro-shaders-slang)
-makedepends=(git)
-source=(libretro-shaders-slang::git+https://github.com/libretro/slang-shaders.git)
-sha256sums=(SKIP)
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# Contributor: Anthony Wang <ta180m@pm.me>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+_pkgname=libretro-shaders-slang
+pkgname=$_pkgname-git
+pkgver=r1257.755b4bb
+pkgrel=1
+pkgdesc="Collection of shaders for libretro"
+arch=('any')
+url="https://github.com/libretro/slang-shaders"
+license=('BSD' 'CCPL' 'GPL2' 'GPL3' 'LGPL2.1' 'LGPL3' 'MIT' 'MPL2' 'Unlicense')
+groups=('libretro')
+makedepends=('git')
+optdepends=('retroarch')
+provides=("$_pkgname=${pkgver#r}" 'libretro-shaders')
+conflicts=("$_pkgname")
+options=('!strip')
+source=("$_pkgname::git+$url.git")
+b2sums=('SKIP')
pkgver() {
- cd libretro-shaders-slang
-
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- make DESTDIR="${pkgdir}" -C libretro-shaders-slang install
+ # shellcheck disable=SC2154
+ make -C $_pkgname DESTDIR="$pkgdir" install
}
-
-# vim: ts=2 sw=2 et: