summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2023-03-31 23:30:30 +0200
committerAlexandre Bouvier2023-03-31 23:30:30 +0200
commitbd1f0216e6f0ec359b4a5058d0bbb4b9ced152e9 (patch)
tree3512831a70c51db6bf457e9c4c56917406a7a3ed
downloadaur-bd1f0216e6f0ec359b4a5058d0bbb4b9ced152e9.tar.gz
update to 0.7.r256.gf7f8744
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddee908acc97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libretro-virtualxt-git
+ pkgdesc = IBM PC/XT core
+ pkgver = 0.7.r256.gf7f8744
+ pkgrel = 1
+ url = https://virtualxt.org/
+ arch = aarch64
+ arch = armv7h
+ arch = i486
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ groups = libretro
+ license = custom
+ makedepends = git
+ depends = glibc
+ depends = libretro-core-info
+ provides = libretro-virtualxt=0.7.r256.gf7f8744
+ conflicts = libretro-virtualxt
+ source = virtualxt::git+https://github.com/andreas-jonsson/virtualxt.git
+ b2sums = SKIP
+
+pkgname = libretro-virtualxt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9c879404ee3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+_pkgname=libretro-virtualxt
+pkgname=$_pkgname-git
+pkgver=0.7.r256.gf7f8744
+pkgrel=1
+pkgdesc="IBM PC/XT core"
+arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
+url="https://virtualxt.org/"
+license=('custom')
+groups=('libretro')
+depends=('glibc' 'libretro-core-info')
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=('virtualxt::git+https://github.com/andreas-jonsson/virtualxt.git')
+b2sums=('SKIP')
+
+pkgver() {
+ cd virtualxt
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd virtualxt
+ sed -i 's/-O[0123s]//;s/-Ofast//' tools/package/libretro/Makefile
+}
+
+build() {
+ cd virtualxt
+ make -C tools/package/libretro
+}
+
+package() {
+ cd virtualxt
+ # shellcheck disable=SC2154
+ install -Dm644 -t "$pkgdir"/usr/lib/libretro tools/package/libretro/virtualxt_libretro.so
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}