summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-08-27 16:18:23 +0200
committerMaxime Gauduin2015-08-27 16:18:23 +0200
commitc4aa79b32264a4d0f8bc030e01a1f2938c2a19a2 (patch)
treeb1c460e13c35d8e8b2b41fde58e2c178a8674234
downloadaur-c4aa79b32264a4d0f8bc030e01a1f2938c2a19a2.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--MKPKG5
-rw-r--r--PKGBUILD40
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d873140dbb38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libretro-yabause-git
+ pkgdesc = Sega Saturn libretro core
+ pkgver = r2680.679eee6
+ pkgrel = 1
+ url = https://github.com/libretro/yabause
+ arch = i686
+ arch = x86_64
+ groups = libretro
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ provides = libretro-yabause
+ conflicts = libretro-yabause
+ source = libretro-yabause::git+https://github.com/libretro/yabause.git
+ source = https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/yabause_libretro.info
+ sha256sums = SKIP
+ sha256sums = 64b9031e2aee5c0cb821e0b9c6c1b1f2e4ca68d23d0288054a067f730ae350d9
+
+pkgname = libretro-yabause-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..9b7779cd9633
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,5 @@
+pkgname=('libretro-yabause-git')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d231248cbe40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=libretro-yabause-git
+pkgver=r2680.679eee6
+pkgrel=1
+pkgdesc='Sega Saturn libretro core'
+arch=('i686' 'x86_64')
+url='https://github.com/libretro/yabause'
+license=('GPL2')
+groups=('libretro')
+depends=('glibc')
+makedepends=('git')
+provides=('libretro-yabause')
+conflicts=('libretro-yabause')
+source=('libretro-yabause::git+https://github.com/libretro/yabause.git'
+ 'https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/yabause_libretro.info')
+sha256sums=('SKIP'
+ '64b9031e2aee5c0cb821e0b9c6c1b1f2e4ca68d23d0288054a067f730ae350d9')
+
+pkgver() {
+ cd libretro-yabause
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd libretro-yabause/libretro
+
+ make
+}
+
+package() {
+ cd libretro-yabause/libretro
+
+ install -dm 755 "${pkgdir}"/usr/{lib/libretro,share/libretro/info}
+ install -m 644 yabause_libretro.so "${pkgdir}"/usr/lib/libretro/
+ install -m 644 ../../yabause_libretro.info "${pkgdir}"/usr/share/libretro/info/
+}
+
+# vim: ts=2 sw=2 et: