summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Pfeiffer2016-08-25 16:03:23 -0500
committerEric Pfeiffer2016-08-25 16:03:23 -0500
commitce67a204086726ed08999ea9e316aee69f7ae90f (patch)
treef12a1e601b378c43b2450efdb8edcaefc94fce1a
downloadaur-ce67a204086726ed08999ea9e316aee69f7ae90f.tar.gz
Initial Release.
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a054085af89f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = librevault
+ pkgdesc = File synchronization designed with privacy in mind
+ pkgver = 0.1.18.6
+ pkgrel = 1
+ url = https://librevault.com/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ depends = qt5-websockets
+ depends = qt5-svg
+ depends = protobuf3>=3.0.0-1
+ depends = boost-libs
+ depends = crypto++
+ depends = miniupnpc
+ depends = qt5-tools
+ depends = websocketpp
+ depends = qt5-base
+ depends = openssl
+ depends = libnatpmp
+ depends = sqlite
+ conflicts = librevault-git
+ source = git+https://github.com/Librevault/librevault.git#tag=v0.1.18.6
+ md5sums = SKIP
+
+pkgname = librevault
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aba737413d5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Eric Pfeiffer <aur@computerfr33k.com>
+pkgname=librevault
+pkgver=0.1.18.6
+pkgrel=1
+pkgdesc="File synchronization designed with privacy in mind"
+arch=(x86_64 i686)
+url="https://librevault.com/"
+license=('GPL3')
+groups=()
+makedepends=('git' 'cmake' 'boost')
+depends=(
+ 'qt5-websockets' 'qt5-svg' 'protobuf3>=3.0.0-1' 'boost-libs'
+ 'crypto++' 'miniupnpc' 'qt5-tools' 'websocketpp' 'qt5-base'
+ 'openssl' 'libnatpmp' 'sqlite'
+)
+conflicts=("${pkgname}-git")
+replaces=()
+backup=()
+options=()
+install=
+source=(
+ "git+https://github.com/Librevault/librevault.git#tag=v$pkgver"
+)
+noextract=()
+md5sums=('SKIP')
+
+prepare() {
+ mkdir -p ${srcdir}/${pkgname}/build && cd ${srcdir}/${pkgname}/build
+ git submodule update --init
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_TESTS=OFF \
+ -DWITH_EXAMPLE=OFF ..
+}
+
+build() {
+ cd ${srcdir}/${pkgname}/build
+ cmake --build .
+}
+
+package() {
+ cd ${srcdir}/${pkgname}/build
+ make DESTDIR="$pkgdir" install
+}