summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2016-08-19 21:18:39 -0400
committerCody P Schafer2016-08-19 21:20:01 -0400
commitfedb2c8ed5cdff320a8466e6bff1d47d679d3990 (patch)
treeb6a736183b2181a1666944e384bdb6bda8e49c19
downloadaur-fedb2c8ed5cdff320a8466e6bff1d47d679d3990.tar.gz
initial
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD67
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f23179ed0cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = librevault-git
+ pkgdesc = File synchronization designed with privacy in mind
+ pkgver = 0.1.18.5.r0.86a6aef
+ pkgrel = 1
+ url = https://librevault.com/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-websockets
+ depends = protobuf3>=3.0.0-1
+ provides = librevault
+ conflicts = librevault
+ source = librevault::git+https://github.com/Librevault/librevault.git
+ source = common::git+https://github.com/Librevault/librevault-common.git
+ source = dir_monitor::git+https://github.com/Librevault/dir_monitor.git
+ source = spdlog::git+https://github.com/Librevault/spdlog.git
+ source = docopt::git+https://github.com/Librevault/docopt.cpp.git
+ source = rabin::git+https://github.com/Librevault/rabin.git
+ source = libnatpmp::git+https://github.com/Librevault/libnatpmp.git
+ source = websocketpp::git+https://github.com/Librevault/websocketpp
+ source = dht::git+https://github.com/Librevault/dht.git
+ source = miniupnp::git+https://github.com/Librevault/miniupnp.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = librevault-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..625c5d02597e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Cody P Schafer <aur@codyps.com>
+pkgname=librevault-git
+pkgver=0.1.18.5.r0.86a6aef
+pkgrel=1
+pkgdesc="File synchronization designed with privacy in mind"
+arch=(x86_64 i686)
+url="https://librevault.com/"
+license=('GPL')
+groups=()
+makedepends=('git' 'cmake')
+depends=('qt5-websockets' 'protobuf3>=3.0.0-1')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=(
+ 'librevault::git+https://github.com/Librevault/librevault.git'
+ 'common::git+https://github.com/Librevault/librevault-common.git'
+ 'dir_monitor::git+https://github.com/Librevault/dir_monitor.git'
+ 'spdlog::git+https://github.com/Librevault/spdlog.git'
+ 'docopt::git+https://github.com/Librevault/docopt.cpp.git'
+ 'rabin::git+https://github.com/Librevault/rabin.git'
+ 'libnatpmp::git+https://github.com/Librevault/libnatpmp.git'
+ 'websocketpp::git+https://github.com/Librevault/websocketpp'
+ 'dht::git+https://github.com/Librevault/dht.git'
+ 'miniupnp::git+https://github.com/Librevault/miniupnp.git'
+)
+noextract=()
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ mkdir -p build
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git config submodule.common.url "$srcdir/common"
+ git config submodule.contrib/dir_monitor.url "$srcdir/dir_monitor"
+ git config submodule.contrib/spdlog.url "$srcdir/spdlog"
+ git config submodule.contrib/docopt.url "$srcdir/docopt"
+ git config submodule.contrib/rabin.url "$srcdir/rabin"
+ git config submodule.contrib/libnatpmp.url "$srcdir/libnatpmp"
+ git config submodule.contrib/websocketpp.url "$srcdir/websocketpp"
+ git config submodule.contrib/dht.url "$srcdir/dht"
+ git config submodule.contrib/miniupnp.url "$srcdir/miniupnp"
+ git submodule update
+}
+
+build() {
+ cd build
+ cmake "$srcdir/${pkgname%-git}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTING=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}