summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris. H2019-07-13 00:05:34 +0200
committerChris. H2019-07-13 00:05:34 +0200
commited317932146bc5d1e26705453ee8816161aa53cf (patch)
tree839b5df6b558cba5923c2ebbdd899eed738e1fb8
parente255bce92443ec75137828068cdd80f21fde25ef (diff)
downloadaur-ed317932146bc5d1e26705453ee8816161aa53cf.tar.gz
v68.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD116
-rw-r--r--librewolf.cfg.patch52
3 files changed, 103 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00d92bdf72b1..4fc8ff7f9f2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = librewolf
pkgdesc = Community-maintained fork of Librefox: a privacy and security-focused browser
- pkgver = 67.0.4
+ pkgver = 68.0
pkgrel = 1
url = https://LibreWolf.gitlab.io
arch = x86_64
@@ -18,7 +18,6 @@ pkgbase = librewolf
makedepends = xorg-server-xvfb
makedepends = autoconf2.13
makedepends = rust
- makedepends = mercurial
makedepends = clang
makedepends = llvm
makedepends = jack
@@ -47,15 +46,13 @@ pkgbase = librewolf
optdepends = hunspell-en_US: Spell checking, American English
options = !emptydirs
options = !makeflags
- source = https://hg.cdn.mozilla.net/mozilla-unified/ae67b187427ebaa695597d65de077c886fe37b7a.zstd-max.hg
- source = 0001-bz-1521249.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/0001-bz-1521249.patch?h=packages/firefox
+ source = https://archive.mozilla.org/pub/firefox/releases/68.0/source/firefox-68.0.source.tar.xz
source = librewolf.desktop
source = librewolf.cfg.patch
- source = git+https://gitlab.com/librewolf-community/librewolf.git#commit=634710ed
- sha256sums = 8fb3423714095b206103649cb179f4997b6f85a616994e106146df19aee778f7
- sha256sums = d0673786a6a1f1b9f6f66a3a1356afa33f1f18f59dabd92bd193c88c52a1d04c
+ source = git+https://gitlab.com/librewolf-community/librewolf.git#commit=a9a64b7f
+ sha256sums = f7d61a08820088f1280d27f0808e355152c1dd0c94625fd077ced7319e522565
sha256sums = 0471d32366c6f415f7608b438ddeb10e2f998498c389217cdd6cc52e8249996b
- sha256sums = b4bfff32d4a385f5075e0cc4df72574c51c68aad3ec4182eb582f95bee59cabf
+ sha256sums = 5b748388c83fae3d09978f845b0211692ebb9191e28709c7e04daf0f49a5ea48
sha256sums = SKIP
pkgname = librewolf
diff --git a/PKGBUILD b/PKGBUILD
index 2221da572fcf..9d3a28eb3909 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,7 @@
pkgname=librewolf
_pkgname=LibreWolf
-pkgver=67.0.4
-_bundle=ae67b187427ebaa695597d65de077c886fe37b7a
+pkgver=68.0
pkgrel=1
pkgdesc="Community-maintained fork of Librefox: a privacy and security-focused browser"
arch=(x86_64)
@@ -15,7 +14,7 @@ url="https://LibreWolf.gitlab.io"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
ffmpeg nss ttf-font libpulse)
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
- xorg-server-xvfb autoconf2.13 rust mercurial clang llvm jack gtk2
+ xorg-server-xvfb autoconf2.13 rust clang llvm jack gtk2
python nodejs python2-psutil cbindgen nasm git inkscape)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
@@ -23,65 +22,71 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'speech-dispatcher: Text-to-Speech'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags)
-_repo=https://hg.mozilla.org/mozilla-unified
-source=(https://hg.cdn.mozilla.net/mozilla-unified/${_bundle}.zstd-max.hg
- "0001-bz-1521249.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/0001-bz-1521249.patch?h=packages/firefox"
+source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
$pkgname.desktop
$pkgname.cfg.patch
- "git+https://gitlab.com/${pkgname}-community/${pkgname}.git#commit=634710ed")
- # "hg+$_repo#tag=FIREFOX_${_pkgver//./_}_RELEASE"
-sha256sums=('8fb3423714095b206103649cb179f4997b6f85a616994e106146df19aee778f7'
- 'd0673786a6a1f1b9f6f66a3a1356afa33f1f18f59dabd92bd193c88c52a1d04c'
+ "git+https://gitlab.com/${pkgname}-community/${pkgname}.git#commit=a9a64b7f")
+sha256sums=('f7d61a08820088f1280d27f0808e355152c1dd0c94625fd077ced7319e522565'
'0471d32366c6f415f7608b438ddeb10e2f998498c389217cdd6cc52e8249996b'
- 'b4bfff32d4a385f5075e0cc4df72574c51c68aad3ec4182eb582f95bee59cabf'
+ '5b748388c83fae3d09978f845b0211692ebb9191e28709c7e04daf0f49a5ea48'
'SKIP')
+#
+# For telemetry and crash dump analysis to work correctly, we need to tell the
+# build system which Mercurial changeset is our source. Should not be needed
+# anymore once 69 is released:
+# https://bugzilla.mozilla.org/show_bug.cgi?id=1338099
+# _repo=https://hg.mozilla.org/releases/mozilla-release
+# _tag=FIREFOX_${pkgver//./_}_RELEASE
+#
+# _changeset=353628fec415324ca6aa333ab6c47d447ecc128e
+# _changeset_tag=FIREFOX_68_0_RELEASE
+#
+# if [[ $1 == update_hgrev ]]; then
+ # _changeset=$(hg id -r $_tag --id $_repo --template '{node}')
+ # sed -e "/^_changeset=/s/=.*/=$_changeset/;/^_changeset_tag=/s/=.*/=$_tag/" \
+ # -i "${BASH_SOURCE[0]}"
+ # exit 0
+# elif [[ $_tag != $_changeset_tag ]]; then
+ # error "Changeset needs update. Run: bash PKGBUILD update_hgrev"
+ # exit 1
+# fi
prepare() {
mkdir mozbuild
- mkdir mozilla-unified
-
- # hg clone failed / timed out on my machines so we use a bundle
- hg init mozilla-unified
- cd mozilla-unified
- hg unbundle ${srcdir}/${_bundle}.zstd-max.hg
- cat > .hg/hgrc <<END
-[paths]
-default = https://hg.mozilla.org/mozilla-unified/
-END
- hg pull
- hg update "FIREFOX_${pkgver//./_}_RELEASE"
-
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1521249
- patch -Np1 -i ../0001-bz-1521249.patch
+ cd firefox-$pkgver
# NOTE:
- # unlock some prefs I deem worthy of keeping unlocked
+ # unlock some prefs I deem worthy of keeping unlocked or slightly less restricted
# (with librewolf installed systemwide, you'd otherwise always have to sudo around in /usr/lib)
# it mainly keeps addon update / install settings / urls unlocked
# as well as form fill settings
- # uncomment it if you are OK with a slight potential decrease in privacy
+ # uncomment it if you are OK with a slight potential decrease in privacy,
+ # or even better: check what I'm doing there.
# cd ${srcdir}/${pkgname}
# patch -Np1 -i ${srcdir}/${pkgname}.cfg.patch
- # cd ${srcdir}/mozilla-unified
-
+ # cd ${srcdir}/firefox-$pkgver
local ICON_FOLDER=$srcdir/$pkgname/branding/icon
- local BRANDING_FOLDER=$srcdir/$pkgname/browser/resources/source_files/browser/branding/librewolf
+ local BRANDING_FOLDER=$srcdir/$pkgname/browser/common/source_files/browser/branding/$pkgname
# generate icons and moves them to the branding folder
- echo Generating icons from $ICON_FILE_PATH and moving to $BRANDING_FOLDER_PATH;
- inkscape --without-gui --file=$ICON_FOLDER/icon.svg --export-png=$BRANDING_FOLDER/default16.png --export-width=16 --export-height=16
- inkscape --without-gui --file=$ICON_FOLDER/icon.svg --export-png=$BRANDING_FOLDER/default32.png --export-width=32 --export-height=32
- inkscape --without-gui --file=$ICON_FOLDER/icon.svg --export-png=$BRANDING_FOLDER/default48.png --export-width=48 --export-height=48
- inkscape --without-gui --file=$ICON_FOLDER/icon.svg --export-png=$BRANDING_FOLDER/default64.png --export-width=64 --export-height=64
- inkscape --without-gui --file=$ICON_FOLDER/icon.svg --export-png=$BRANDING_FOLDER/default128.png --export-width=128 --export-height=128
- inkscape --without-gui --file=$ICON_FOLDER/icon.svg --export-png=$BRANDING_FOLDER/VisualElements_70.png --export-width=70 --export-height=70
- inkscape --without-gui --file=$ICON_FOLDER/icon.svg --export-png=$BRANDING_FOLDER/VisualElements_150.png --export-width=150 --export-height=150
+ echo Generating icons from $ICON_FOLDER and moving to $BRANDING_FOLDER;
+ inkscape -z -f $ICON_FOLDER/icon.svg -e $BRANDING_FOLDER/default16.png -w 16 -h 16
+ inkscape -z -f $ICON_FOLDER/icon.svg -e $BRANDING_FOLDER/default32.png -w 32 -h 32
+ inkscape -z -f $ICON_FOLDER/icon.svg -e $BRANDING_FOLDER/default48.png -w 48 -h 48
+ inkscape -z -f $ICON_FOLDER/icon.svg -e $BRANDING_FOLDER/default64.png -w 64 -h 64
+ inkscape -z -f $ICON_FOLDER/icon.svg -e $BRANDING_FOLDER/default128.png -w 128 -h 128
+ inkscape -z -f $ICON_FOLDER/icon.svg -e $BRANDING_FOLDER/VisualElements_70.png -w 70 -h 70
+ inkscape -z -f $ICON_FOLDER/icon.svg -e $BRANDING_FOLDER/VisualElements_150.png -w 150 -h 150
cat >.mozconfig <<END
ac_add_options --enable-application=browser
+# This supposedly speeds up compilation (We test through dogfooding anyway)
+ac_add_options --disable-tests
+ac_add_options --disable-debug
+
ac_add_options --prefix=/usr
ac_add_options --enable-release
ac_add_options --enable-hardening
@@ -101,16 +106,12 @@ ac_add_options --enable-update-channel=release
ac_add_options --with-app-name=${pkgname}
ac_add_options --with-app-basename=${_pkgname}
ac_add_options --with-branding=browser/branding/${pkgname}
-ac_add_options --with-distribution-id=io.github.${pkgname}
-export MOZ_APP_REMOTINGNAME=${_pkgname//-/}
+ac_add_options --with-distribution-id=io.gitlab.${pkgname}
+ac_add_options --with-unsigned-addon-scopes=app,system
+# export MOZ_APP_REMOTINGNAME=${_pkgname//-/}
# export MOZ_TELEMETRY_REPORTING=0
export MOZ_REQUIRE_SIGNING=1
-# Keys
-# ac_add_options --with-google-location-service-api-keyfile=${PWD@Q}/google-api-key
-# ac_add_options --with-google-safebrowsing-api-keyfile=${PWD@Q}/google-api-key
-# ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
-
# System libraries
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
@@ -122,14 +123,23 @@ ac_add_options --enable-startup-notification
ac_add_options --disable-crashreporter
ac_add_options --disable-gconf
ac_add_options --disable-updater
+
+# Disables crash reporting, telemetry and other data gathering tools
+mk_add_options MOZ_CRASHREPORTER=0
+mk_add_options MOZ_DATA_REPORTING=0
+mk_add_options MOZ_SERVICES_HEALTHREPORT=0
+mk_add_options MOZ_TELEMETRY_REPORTING=0
END
- cp -r ${srcdir}/${pkgname}/browser/resources/source_files/{docshell,browser} ./
+ cp -r ${srcdir}/${pkgname}/browser/common/source_files/browser ./
+
+ # Disabling Pocket
+ sed -i "s/'pocket'/#'pocket'/g" ./browser/components/moz.build
}
build() {
- cd mozilla-unified
+ cd firefox-$pkgver
export MOZ_SOURCE_REPO="$_repo"
export MOZ_NOSPAM=1
@@ -145,9 +155,9 @@ build() {
}
package() {
- cd mozilla-unified
+ cd firefox-$pkgver
DESTDIR="$pkgdir" ./mach install
- find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
+ # find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
_vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END
@@ -165,12 +175,12 @@ pref("extensions.autoDisableScopes", 11);
pref("extensions.shownSelectionUI", true);
END
- cp -r ${srcdir}/${pkgname}/settings/settings/* $pkgdir/usr/lib/$pkgname
+ cp -r ${srcdir}/${pkgname}/settings/* $pkgdir/usr/lib/$pkgname
_distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
install -Dm644 /dev/stdin "$_distini" <<END
[Global]
-id=io.github.${pkgname}
+id=io.gitlab.${pkgname}
version=1.0
about=LibreWolf Arch Linux
@@ -205,5 +215,3 @@ END
ln -srf "$pkgdir/usr/bin/$pkgname" \
"$pkgdir/usr/lib/$pkgname/librewolf-bin"
}
-
-# vim:set sw=2 et:
diff --git a/librewolf.cfg.patch b/librewolf.cfg.patch
index eb04a86f2ac0..a09070bae2f2 100644
--- a/librewolf.cfg.patch
+++ b/librewolf.cfg.patch
@@ -1,7 +1,7 @@
-diff --git a/settings/settings/librewolf.cfg b/settings/settings/librewolf.cfg
-index befdb47..54b6841 100644
---- a/settings/settings/librewolf.cfg
-+++ b/settings/settings/librewolf.cfg
+diff --git a/settings/librewolf.cfg b/settings/librewolf.cfg
+index 9b60c51..de990d5 100644
+--- a/settings/librewolf.cfg
++++ b/settings/librewolf.cfg
@@ -91,14 +91,14 @@ lockPref("general.config.filename", "librewolf.cfg");
// http://kb.mozillazine.org/Network.cookie.cookieBehavior#1
// Blocking 3rd-party cookies breaks a number of payment gateways
@@ -28,7 +28,16 @@ index befdb47..54b6841 100644
lockPref("network.cookie.thirdparty.nonsecureSessionOnly", true); // (FF58+) // default false
// Also check "User Settings : Track Protection" for other cookies settings
-@@ -353,10 +353,10 @@ lockPref("browser.sessionstore.interval", 60000);
+@@ -289,6 +289,8 @@ defaultPref("privacy.sanitize.sanitizeOnShutdown", true);
+
+ // Pref : Defaulting Settings : Does not remember history
+ defaultPref("places.history.enabled", false);
++// w.r. to issue #54
++defaultPref("places.history.expiration.max_pages", 2147483647)
+
+ // Pref : Settings history settings to custom by default
+ defaultPref("privacy.history.custom", true);
+@@ -360,10 +362,10 @@ lockPref("browser.sessionstore.interval", 60000);
// ----------------------------------------------------------------------------------------------------
// Pref : Forms auto fill
@@ -43,7 +52,7 @@ index befdb47..54b6841 100644
// Pref : Require manual intervention to autofill known username/passwords in sign-in forms
// http://kb.mozillazine.org/Signon.autofillForms
-@@ -757,13 +757,13 @@ lockPref("dom.w3c_pointer_events.enabled", false);
+@@ -761,13 +763,13 @@ lockPref("dom.w3c_pointer_events.enabled", false);
// Pref : Enable hardening against various fingerprinting vectors (Tor Uplift project)
// https://wiki.mozilla.org/Security/Tor_Uplift/Tracking
// https://bugzilla.mozilla.org/show_bug.cgi?id=1333933
@@ -59,16 +68,21 @@ index befdb47..54b6841 100644
// >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
// Section : Locale/Time/UserAgent
-@@ -789,7 +789,7 @@ lockPref("intl.regional_prefs.use_os_locales", false);
+@@ -793,11 +795,11 @@ lockPref("intl.regional_prefs.use_os_locales", false);
// Pref : Locale and useragent.
// Already applied by resistFingerprinting ?
-lockPref("intl.locale.requested", "en-US");
+defaultPref("intl.locale.requested", "en-US");
- // Pref : Spoof User-agent (disabled)
- // Disabled to make resistFingerprinting efficient
-@@ -1073,7 +1073,8 @@ lockPref("extensions.webextensions.identity.redirectDomain", "");
+ // Pref : Spoof User-agent (re-enabled)
+ // See https://gitlab.com/librewolf-community/librewolf/issues/26
+-lockPref("general.useragent.override", "Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0, 45");
++defaultPref("general.useragent.override", "Mozilla/5.0 (Windows NT 6.1; rv:45.0) Gecko/20100101 Firefox/45.0, 45");
+
+ // Pref : This does not work with resistFingerprinting. Still needed for ESR.
+ lockPref("general.appname.override", "Netscape");
+@@ -1077,7 +1079,8 @@ lockPref("extensions.webextensions.identity.redirectDomain", "");
// Pref : CSP Settings For Extensions I/II : Extension Firewall Feature
// Uncomment to disable network for the extensions
// Enable-Firewall-Feature-In-The-Next-Line extensions-firewall >>>>>>
@@ -78,7 +92,7 @@ index befdb47..54b6841 100644
// Pref : CSP Settings For Extensions II/II : Extension Firewall Feature
// This value is applied after the first one (just ignore this)
-@@ -1415,22 +1416,22 @@ lockPref("extensions.getAddons.compatOverides.url", "");
+@@ -1419,22 +1422,22 @@ lockPref("extensions.getAddons.compatOverides.url", "");
// https://services.addons.mozilla.org/api/v3/addons/compat-override/?guid=%IDS%&lang=%LOCALE%
// Pref :
@@ -105,7 +119,7 @@ index befdb47..54b6841 100644
// Default Value
// https://addons.mozilla.org/%LOCALE%/firefox/search?q=%TERMS%&platform=%OS%&appver=%VERSION%
-@@ -1465,7 +1466,7 @@ lockPref("browser.newtabpage.activity-stream.fxaccounts.endpoint", "");
+@@ -1469,7 +1472,7 @@ lockPref("browser.newtabpage.activity-stream.fxaccounts.endpoint", "");
// https://accounts.firefox.com/
// Pref :
@@ -114,7 +128,7 @@ index befdb47..54b6841 100644
// Default Value
// https://versioncheck.addons.mozilla.org/update/VersionCheck.php?reqVersion=
// %REQ_VERSION%&id=%ITEM_ID%&version=%ITEM_VERSION%&maxAppVersion=
-@@ -2061,7 +2062,7 @@ lockPref("app.releaseNotesURL", "");
+@@ -2065,7 +2068,7 @@ lockPref("app.releaseNotesURL", "");
// Pref :
lockPref("app.update.auto", false);
@@ -123,7 +137,7 @@ index befdb47..54b6841 100644
lockPref("app.update.staging.enabled", false);
lockPref("app.update.silent", false);
lockPref("app.update.lastUpdateTime.telemetry_modules_ping", 0);
-@@ -2175,10 +2176,10 @@ lockPref("extensions.blocklist.itemURL", "");
+@@ -2178,10 +2181,10 @@ lockPref("extensions.blocklist.itemURL", "");
lockPref("extensions.blocklist.url", "");
// Pref :
@@ -136,7 +150,7 @@ index befdb47..54b6841 100644
// Pref :
lockPref("extensions.webservice.discoverURL", "");
-@@ -2470,7 +2471,7 @@ lockPref("security.dialog_enable_delay", 700);
+@@ -2473,7 +2476,7 @@ lockPref("security.dialog_enable_delay", 700);
// Pref : Opt-out of add-on metadata updates
// https://blog.mozilla.org/addons/how-to-opt-out-of-add-on-metadata-updates/
@@ -145,7 +159,7 @@ index befdb47..54b6841 100644
// Pref : Opt-out of theme (Persona) updates
// https://support.mozilla.org/t5/Firefox/how-do-I-prevent-autoamtic-updates-in-a-50-user-environment/td-p/144287
-@@ -2503,7 +2504,7 @@ lockPref("plugin.sessionPermissionNow.intervalInMinutes", 0);
+@@ -2506,7 +2509,7 @@ lockPref("plugin.sessionPermissionNow.intervalInMinutes", 0);
// Pref : Update addons automatically
// https://blog.mozilla.org/addons/how-to-turn-off-add-on-updates/
@@ -154,3 +168,9 @@ index befdb47..54b6841 100644
// Pref : Enable add-on and certificate blocklists (OneCRL) from Mozilla
// Updated at interval defined in extensions.blocklist.interval (default: 86400)
+@@ -3230,4 +3233,4 @@ lockPref("security.tls.unrestricted_rc4_fallback", false);
+ //lockPref("toolkit.telemetry.unifiedIsOptIn", true);
+ //lockPref("ui.key.menuAccessKey", 0);
+ //lockPref("view_source.tab", false);
+-lockPref("xpinstall.signatures.required", false);
++defaultPref("xpinstall.signatures.required", true);