summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonin Dach2021-11-02 21:30:44 +0100
committerAntonin Dach2021-11-02 21:30:44 +0100
commitbe89c1e7f4c030d73a326b6aba63ebdc2a1aca6c (patch)
treee2a26026b8844e6aa9ef1144725a77eb53484837
parentc22691cbd3468f52a9661763b547015c00a6bddc (diff)
downloadaur-be89c1e7f4c030d73a326b6aba63ebdc2a1aca6c.tar.gz
in CI, use git to fetch pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 808ad62a4317..e655502297e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = librewolf-firefox-shim
pkgdesc = A symlink for using librewolf as a firefox
- pkgver = 89.0.2
+ pkgver = 93.0
pkgrel = 1
url = https://librewolf-community.gitlab.io/
arch = any
license = MIT
depends = librewolf
- provides = firefox=89.0.2
+ provides = firefox=93.0
conflicts = firefox
pkgname = librewolf-firefox-shim
diff --git a/PKGBUILD b/PKGBUILD
index 0bb570844031..be595f6eb0fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Antonin Dach <dach@protonmail.com>
pkgname=librewolf-firefox-shim
-pkgver=89.0.2
+pkgver=93.0
pkgrel=1
pkgdesc="A symlink for using librewolf as a firefox"
arch=('any')
@@ -15,7 +15,13 @@ conflicts=(
)
pkgver() {
- pacman -Qi librewolf | grep -E '^Version[[:space:]]*:' | head -n 1 | awk -F ':' '{print $2}' | sed -E 's|-.*||' | tr -d '[[:space:]]'
+ if [[ $CI == true ]]; then
+ # Assuming build runner is without extra and has online access
+ git ls-remote https://gitlab.com/librewolf-community/browser/arch | tail -n 1 | cut -d/ -f3 | cut -c 2- | cut -d- -f1
+ else
+ pacman -Qi librewolf | grep -E '^Version[[:space:]]*:' | head -n 1 | awk -F ':' '{print $2}' | sed -E 's|-.*||' | tr -d '[[:space:]]'
+
+ fi
}
package() {