summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonin Dach2021-07-29 15:51:41 +0200
committerAntonin Dach2021-07-29 15:51:41 +0200
commitc22691cbd3468f52a9661763b547015c00a6bddc (patch)
tree3fce4df6d00ddcf9f61653d4ff2ec720c5513da9
parent6a1ad9f21c68f6fccb7337d44c0d4f9c2113d3a8 (diff)
downloadaur-c22691cbd3468f52a9661763b547015c00a6bddc.tar.gz
Adding pkgver() function.
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD6
3 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16ca83814df6..808ad62a4317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = librewolf-firefox-shim
pkgdesc = A symlink for using librewolf as a firefox
- pkgver = 87.0
+ pkgver = 89.0.2
pkgrel = 1
url = https://librewolf-community.gitlab.io/
arch = any
license = MIT
depends = librewolf
- provides = firefox=87.0
+ provides = firefox=89.0.2
conflicts = firefox
pkgname = librewolf-firefox-shim
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fbf3a109d68a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg
+*.tar.zst
+*.tar
diff --git a/PKGBUILD b/PKGBUILD
index 8841331499de..0bb570844031 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Antonin Dach <dach@protonmail.com>
pkgname=librewolf-firefox-shim
-pkgver=87.0
+pkgver=89.0.2
pkgrel=1
pkgdesc="A symlink for using librewolf as a firefox"
arch=('any')
@@ -14,6 +14,10 @@ conflicts=(
"firefox"
)
+pkgver() {
+ pacman -Qi librewolf | grep -E '^Version[[:space:]]*:' | head -n 1 | awk -F ':' '{print $2}' | sed -E 's|-.*||' | tr -d '[[:space:]]'
+}
+
package() {
install -d "$pkgdir"/usr/bin
ln -s /usr/bin/librewolf "$pkgdir"/usr/bin/firefox