summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Nepogodin2021-11-11 00:10:52 +0400
committerVladislav Nepogodin2021-11-11 00:10:52 +0400
commit4c8d12860a202496fd89cf3113e0e035c4900e54 (patch)
tree04f14d18a46b2490eaa415064cfb95502a579cbe
parent86d133b67d93e97407c1ffa43af1f5fbc4e5730f (diff)
downloadaur-4c8d12860a202496fd89cf3113e0e035c4900e54.tar.gz
fix Bug 1571559
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a725273d317..f7f8d115340c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -35,6 +35,7 @@ pkgbase = librewolf-hg
makedepends = binutils
makedepends = lld
makedepends = dump_syms
+ makedepends = wasi-sdk-git
depends = gtk3
depends = libxt
depends = mime-types
diff --git a/PKGBUILD b/PKGBUILD
index 8c99a3ba2900..06f3e1c14c20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,8 @@ depends=(gtk3 libxt mime-types dbus-glib
makedepends=(unzip zip diffutils yasm mesa imake inetutils ccache
rust xorg-server-xwayland xorg-server-xvfb
autoconf2.13 mercurial clang llvm jack nodejs cbindgen nasm
- python-setuptools python-psutil python-zstandard git binutils lld dump_syms)
+ python-setuptools python-psutil python-zstandard git binutils lld dump_syms
+ wasi-sdk-git)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'pulseaudio: Audio support'
@@ -73,6 +74,11 @@ ac_add_options --enable-default-toolkit=cairo-gtk3-wayland
export CC='clang'
export CXX='clang++'
+# wasi sdk
+ac_add_options --with-wasi-sysroot=/opt/wasi-sdk/share/wasi-sysroot
+export WASM_CC=/opt/wasi-sdk/bin/clang
+export WASM_CXX=/opt/wasi-sdk/bin/clang++
+
# Branding
ac_add_options --enable-update-channel=nightly
ac_add_options --with-app-name=${_pkgname}