summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Nepogodin2021-03-21 15:07:40 +0400
committerVladislav Nepogodin2021-03-21 15:07:40 +0400
commite6c6dd92391ec43cd9cd68f58fae777a97ba243d (patch)
treed953f15218410b3b7ce6da345fcc3c8dbed5954a
parentfacaf84ebc4e593d88b0ef9074dca491a8e73e3e (diff)
downloadaur-e6c6dd92391ec43cd9cd68f58fae777a97ba243d.tar.gz
Rename librewolf-nightly-bin -> librewolf-bin
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fffba1fd33e7..4caf5512ec62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -44,12 +44,13 @@ pkgbase = librewolf-nightly
depends = nss-hg
depends = ttf-font
depends = libpulse
+ depends = libopenaptx
depends = libvpx
depends = libjpeg
depends = zlib
depends = icu
depends = libevent
- depends = libpipewire02
+ depends = pipewire
optdepends = networkmanager: Location detection via available WiFi networks
optdepends = libnotify: Notification integration
optdepends = pulseaudio: Audio support
diff --git a/PKGBUILD b/PKGBUILD
index 74ea3cb2103c..9fe521fc53aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,8 @@ arch=(x86_64 aarch64)
license=(MPL GPL LGPL)
url="https://librewolf-community.gitlab.io/"
depends=(gtk3 libxt mime-types dbus-glib
- ffmpeg nss-hg ttf-font libpulse
- libvpx libjpeg zlib icu libevent libpipewire02)
+ ffmpeg nss-hg ttf-font libpulse libopenaptx
+ libvpx libjpeg zlib icu libevent pipewire)
makedepends=(unzip zip diffutils yasm mesa imake inetutils ccache
rust mozilla-common xorg-server-xwayland xorg-server-xvfb
autoconf2.13 mercurial clang llvm jack gtk2 nodejs cbindgen nasm
@@ -307,6 +307,7 @@ package() {
cd mozilla-unified
DESTDIR="$pkgdir" ./mach install
mv "$pkgdir"/usr/lib/${pkgname}/{$pkgname,librewolf}
+ mv "$pkgdir"/usr/lib/${pkgname}/{$pkgname-bin,librewolf-bin}
rm "$pkgdir"/usr/lib/${pkgname}/pingsender
_vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
@@ -354,13 +355,11 @@ END
"$pkgdir/usr/share/applications/$pkgname.desktop"
# Install a wrapper to avoid confusion about binary path
- install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
+ #install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh
-exec /usr/lib/$pkgname/librewolf "\$@"
-END
+#exec /usr/lib/$pkgname/librewolf "\$@"
+#END
- # Replace duplicate binary with wrapper
- # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -srf "$pkgdir/usr/bin/$pkgname" \
- "$pkgdir/usr/lib/$pkgname/librewolf-bin"
+ ln -srf "$pkgdir"/usr/lib/${pkgname}/librewolf \
+ "$pkgdir"/usr/bin/$pkgname
}