summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordr460nf1r32021-02-02 20:26:05 +0100
committerdr460nf1r32021-02-02 20:26:05 +0100
commit074551b0fe96bb69b15033628d78bf784cd7a874 (patch)
tree93f8ebb2ae0444217a6da26ca891c4c73705a3b5
downloadaur-074551b0fe96bb69b15033628d78bf784cd7a874.tar.gz
Initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..936d5d66b2f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = librewolf-ublock-origin
+ pkgdesc = Efficient blocker add-on for various browsers. Fast, potent, and lean
+ pkgver = 1.33.2
+ pkgrel = 1
+ url = https://github.com/gorhill/uBlock
+ arch = any
+ groups = librewolf-addons
+ license = GPL3
+ makedepends = git
+ makedepends = python
+ makedepends = zip
+ source = git+https://github.com/gorhill/uBlock.git#commit=e13bf4d6d626eae726e09067b2e143bb6271c81f?signed
+ source = git+https://github.com/uBlockOrigin/uAssets.git
+ validpgpkeys = 603B28AA5D6CD687A554347425E1490B761470C2
+ b2sums = SKIP
+ b2sums = SKIP
+
+pkgname = librewolf-ublock-origin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fc13d04ae53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+# Maintainer: dr460nf1r3 <dr460nf1r3@garudalinux.org>
+
+pkgname=librewolf-ublock-origin
+pkgver=1.33.2
+_commit=e13bf4d6d626eae726e09067b2e143bb6271c81f
+pkgrel=1
+pkgdesc='Efficient blocker add-on for various browsers. Fast, potent, and lean'
+arch=('any')
+url=https://github.com/gorhill/uBlock
+license=('GPL3')
+groups=('librewolf-addons')
+makedepends=('git' 'python' 'zip')
+source=("git+$url.git#commit=$_commit?signed"
+ "git+https://github.com/uBlockOrigin/uAssets.git")
+b2sums=('SKIP' 'SKIP')
+validpgpkeys=('603B28AA5D6CD687A554347425E1490B761470C2') # Raymond Hill <rhill@raymondhill.net>
+
+build() {
+ cd uBlock
+ ./tools/make-firefox.sh all
+}
+
+package() {
+ cd uBlock/dist/build
+ install -Dm644 uBlock0.firefox.xpi \
+ "$pkgdir"/usr/lib/librewolf/browser/extensions/uBlock0@raymondhill.net.xpi
+}