summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2020-05-20 20:19:22 +0800
committerCoelacanthus2020-05-20 20:19:22 +0800
commitf7afee1dd4b70569621d5a686605de2867fd9fad (patch)
tree5cca9b7f7aa833d03a8ef345ca82e2fec5de04fb
parent552cc4c2ed1f375e127300696ff98a76ba3556ea (diff)
downloadaur-f7afee1dd4b70569621d5a686605de2867fd9fad.tar.gz
fix
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51fcd9634556..4846037ad9d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,8 @@ pkgbase = librime-lua-git
makedepends = librime-data
makedepends = google-glog
makedepends = marisa
- depends = librimelua
+ depends = librime
+ depends = lua
provides = librime-lua.so
source = librime-lua::git+https://github.com/hchunhui/librime-lua.git
source = librime-1.5.3.tar.gz::https://github.com/rime/librime/archive/1.5.3.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index fac0b7a0ecd1..2c5dadbbbb27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="Rime input method engine with Lua plugin"
arch=('x86_64')
url="https://github.com/hchunhui/librime-lua"
license=('GPL3')
-depends=('librime''lua')
+depends=('librime' 'lua')
makedepends=('git' 'cmake' 'boost' 'gtest' 'boost-libs' 'opencc' 'yaml-cpp' 'leveldb' 'librime-data' 'google-glog' 'marisa')
provides=('librime-lua.so')
#conflicts=('librime' 'librime-lua')
@@ -29,6 +29,8 @@ pkgver() {
prepare() {
cp -r librime-lua $_pkgname-$_pkgver/plugins/lua
+ cd $_pkgname-$_pkgver
+ patch -p1 -i ../$pkgname-opencc-1.1.patch
}
build() {