summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYe Jingchen2019-09-13 17:18:57 +0800
committerYe Jingchen2019-09-13 17:18:57 +0800
commit8f5958fb9bd7130fefc18b852ea75bfed10aeccf (patch)
tree4fbeddd4ef4eeaf7cea095e04b2e09d35fd319e5
downloadaur-8f5958fb9bd7130fefc18b852ea75bfed10aeccf.tar.gz
initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD44
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c27a6a0e826
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = librime-octagram
+ pkgdesc = Rime input method engine, with octagram plugin
+ pkgver = 1.5.3
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/rime/librime
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = boost
+ makedepends = gtest
+ makedepends = git
+ depends = boost-libs
+ depends = opencc
+ depends = yaml-cpp
+ depends = leveldb
+ depends = google-glog
+ depends = marisa
+ optdepends = plum: preset input schemas
+ optdepends = plum-extra: extra input schemas
+ provides = librime
+ conflicts = librime
+ source = librime-1.5.3.tar.gz::https://github.com/rime/librime/archive/1.5.3.tar.gz
+ source = git+https://github.com/lotem/librime-octagram
+ sha512sums = 4d7f6ec43bd5728f59f0b3581bcd8a46128651430b6873017d80659942b8f6aa1a2f25f439ba8fba461fe22acbf701c2da7a786104a2e4852a70a89cdc0452d3
+ sha512sums = SKIP
+
+pkgname = librime-octagram
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4925b6fc8ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: caiye <ye[dot]jingchen[at]gmail[dot]com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: GONG Chen <chen dot sst at gmail dot com>
+# Contributor: 網軍總司令
+
+_projname=librime
+pkgname=librime-octagram
+pkgver=1.5.3
+pkgrel=1
+epoch=1
+pkgdesc="Rime input method engine, with octagram plugin"
+arch=('x86_64')
+url="https://github.com/rime/librime"
+license=('GPL3')
+depends=('boost-libs' 'opencc' 'yaml-cpp' 'leveldb' 'google-glog' 'marisa')
+optdepends=('plum: preset input schemas'
+ 'plum-extra: extra input schemas')
+makedepends=('cmake' 'boost' 'gtest' 'git')
+conflicts=('librime')
+provides=('librime')
+source=("$_projname-$pkgver.tar.gz::https://github.com/rime/librime/archive/$pkgver.tar.gz"
+ "git+https://github.com/lotem/librime-octagram")
+sha512sums=('4d7f6ec43bd5728f59f0b3581bcd8a46128651430b6873017d80659942b8f6aa1a2f25f439ba8fba461fe22acbf701c2da7a786104a2e4852a70a89cdc0452d3'
+ 'SKIP')
+
+prepare() {
+ cd $_projname-$pkgver/plugins
+ if [[ ! -e librime-octagram ]]; then
+ git clone "$srcdir/librime-octagram"
+ else
+ (cd librime-octagram && git pull)
+ fi
+}
+
+build() {
+ cd $_projname-$pkgver
+ cmake . -Bbuild -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ cd $_projname-$pkgver/build
+ make DESTDIR="$pkgdir" install
+}