summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2018-03-22 01:23:15 +0100
committerAlexandre Bouvier2018-03-22 01:23:15 +0100
commitbb291b885e11f041cd1e102dde1bae245d856980 (patch)
treeab1dbcd92da02530ad18762632f15f58b05c4b05
downloadaur-bb291b885e11f041cd1e102dde1bae245d856980.tar.gz
r1744.9232d14
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..076ff0904715
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libringqt-git
+ pkgdesc = A library for GNU Ring, a secure communication platform
+ pkgver = r1744.9232d14
+ pkgrel = 1
+ url = https://github.com/Elv13/libringqt
+ arch = x86_64
+ groups = ring
+ license = LGPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = ring-daemon
+ depends = qt5-base
+ provides = libringqt
+ conflicts = libringqt
+ source = git+https://github.com/Elv13/libringqt.git
+ md5sums = SKIP
+
+pkgname = libringqt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d69714ef06ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+#!/bin/bash
+# shellcheck disable=SC2034,SC2164
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+_pkgname=libringqt
+pkgname=$_pkgname-git
+pkgver=r1744.9232d14
+pkgrel=1
+pkgdesc="A library for GNU Ring, a secure communication platform"
+arch=('x86_64')
+url="https://github.com/Elv13/$_pkgname"
+license=('LGPL')
+groups=('ring')
+depends=('ring-daemon' 'qt5-base')
+makedepends=('git' 'cmake' 'qt5-tools')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../"$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ # shellcheck disable=SC2154
+ make DESTDIR="$pkgdir" install
+}