summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2023-04-12 03:57:43 -0400
committerChris Severance2023-04-12 03:57:43 -0400
commitd5815c18beabbae3392c38e0035ec92a7c966e94 (patch)
tree1b5355c17ee6534d44ec8dc9965e5b5ea7f0fa76
parent47e6e927d0a3021a5b4ef3472a75d9b8127517b5 (diff)
downloadaur-d5815c18beabbae3392c38e0035ec92a7c966e94.tar.gz
autu: Update to 2.0.20-1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d27139f59296..2aad26ebd98e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Thu Jul 5 18:36:32 UTC 2018
pkgbase = librlib
pkgdesc = Advanced reporting engine that generates professional reports in PDF, HTML, CSV, and text formats from a simple XML definition language.
pkgver = 2.0.20
@@ -19,4 +17,3 @@ pkgbase = librlib
sha256sums = 298bef69cb1e1fa5983698081378ab54c2cb143b29d574928b0c771bc7a309a8
pkgname = librlib
-
diff --git a/PKGBUILD b/PKGBUILD
index cd11d66a3e08..fa279c8cf5cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,14 +35,14 @@ sha256sums=('298bef69cb1e1fa5983698081378ab54c2cb143b29d574928b0c771bc7a309a8')
prepare() {
set -u
cd "${_pkgname}-${pkgver}"
- export CPPFLAGS="${CPPFLAGS} -O2 -Wno-misleading-indentation -Wno-unused-parameter -Wno-unused-result"
+ export CXXFLAGS="${CXXFLAGS} -O2 -Wno-misleading-indentation -Wno-unused-parameter -Wno-unused-result"
if [ -f 'autogen.sh' ]; then
# Postgres wants a config file. Perl won't compile. Python configure claims no but is really yes. db2pdf doesn't work.
# Configure gives us a Python.h error that needs to be fixed.
# Python tests error: ImportError: No module named '_rlib'
- ./autogen.sh --prefix='/usr' --enable-utf8 --enable-python --disable-postgres --disable-perl --disable-doc --disable-php
+ ./autogen.sh --prefix='/usr' --enable-utf8 --disable-python --disable-postgres --disable-perl --disable-doc --disable-php
else
- ./configure --prefix='/usr' --enable-utf8 --enable-python --with-pythonver='2.7' --disable-php
+ ./configure --prefix='/usr' --enable-utf8 --disable-python --with-pythonver='2.7' --disable-php
# From http://sisyphus.ru/en/srpm/Branch5/librlib/spec Version: 1.3.7
#./configure --disable-static --with-pythonver=%__python_version --disable-postgres --disable-php --disable-perl --disable-python
fi