summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-07-04 14:07:11 -0400
committerChris Severance2018-07-04 14:07:11 -0400
commitf2df0be062a8031da9cee8b0139ceb140f4ab6d2 (patch)
treeb93702d17cb23772dff07fa480359701aca3a461
parenta92496338a653a13f7f2222685d78eb2d9272524 (diff)
downloadaur-f2df0be062a8031da9cee8b0139ceb140f4ab6d2.tar.gz
autu: Update to 2.0.20-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4106b5cd5f1d..7851735b2321 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 8 07:53:48 UTC 2017
+# Wed Jul 4 18:07:10 UTC 2018
pkgbase = librlib
pkgdesc = Advanced reporting engine that generates professional reports in PDF, HTML, CSV, and text formats from a simple XML definition language.
- pkgver = 2.0.17
+ pkgver = 2.0.20
pkgrel = 1
url = http://rlib.sicompos.com/
arch = i686
@@ -15,8 +15,8 @@ pkgbase = librlib
optdepends = php: php bindings
provides = rlib
provides = libr
- source = rlib-2.0.17.tar.gz::https://github.com/SICOM/rlib/archive/v2.0.17.tar.gz
- sha256sums = 79c793bac264dd8418be7115f6832f92724c44fe98994ad37bc3c2d1173227cb
+ source = rlib-2.0.20.tar.gz::https://github.com/SICOM/rlib/archive/v2.0.20.tar.gz
+ sha256sums = 298bef69cb1e1fa5983698081378ab54c2cb143b29d574928b0c771bc7a309a8
pkgname = librlib
diff --git a/PKGBUILD b/PKGBUILD
index 31ced505ac28..c13d1ffe3181 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
# Contributor: Andrew Grigorev <andrew@ei-grad.ru>
+# TODO: PHP7 compatibility, remove --disable-php
+
# see src/examples
set -u
_gitname='SICOM'
_pkgname='rlib'
pkgname="lib${_pkgname}" # libr seems a bit short
-pkgver='2.0.17'
-# 2.0.10 won't compile
+pkgver='2.0.20'
pkgrel='1'
pkgdesc='Advanced reporting engine that generates professional reports in PDF, HTML, CSV, and text formats from a simple XML definition language.'
arch=('i686' 'x86_64')
@@ -28,7 +29,7 @@ _giturl="https://github.com/${_gitname}/${_pkgname}"
_verwatch=("${_giturl}/releases" "${_giturl#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
#source=("http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.gz") # <=1.3.7
source=("${_pkgname}-${pkgver}.tar.gz::${_giturl}/archive/v${pkgver}.tar.gz")
-sha256sums=('79c793bac264dd8418be7115f6832f92724c44fe98994ad37bc3c2d1173227cb')
+sha256sums=('298bef69cb1e1fa5983698081378ab54c2cb143b29d574928b0c771bc7a309a8')
prepare() {
set -u
@@ -38,9 +39,9 @@ prepare() {
# Postgres wants a config file. Perl won't compile. Python configure claims no but is really yes. db2pdf doesn't work.
# Configure gives us a Python.h error that needs to be fixed.
# Python tests error: ImportError: No module named '_rlib'
- ./autogen.sh --prefix='/usr' --enable-utf8 --enable-python --disable-postgres --disable-perl --disable-doc
+ ./autogen.sh --prefix='/usr' --enable-utf8 --enable-python --disable-postgres --disable-perl --disable-doc --disable-php
else
- ./configure --prefix='/usr' --enable-utf8 --enable-python --with-pythonver='2.7'
+ ./configure --prefix='/usr' --enable-utf8 --enable-python --with-pythonver='2.7' --disable-php
# From http://sisyphus.ru/en/srpm/Branch5/librlib/spec Version: 1.3.7
#./configure --disable-static --with-pythonver=%__python_version --disable-postgres --disable-php --disable-perl --disable-python
fi
@@ -51,7 +52,8 @@ prepare() {
build() {
set -u
cd "${_pkgname}-${pkgver}"
- make -s -j "$(nproc)"
+ local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
+ nice make -s -j "${_nproc}"
set +u
}