summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Boerman2021-01-13 22:26:59 +0100
committerFrank Boerman2021-01-13 22:26:59 +0100
commite65730da4b22158c4848490d2e3a26bc0ba2f6d6 (patch)
treee806fabf6fa2ff2a033e2f3aa6fab10afea7550a
parent202684dc6ff76c77a9b1bee099d61859f2f331ba (diff)
downloadaur-libroboint.tar.gz
added udev rules to the package
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD5
-rw-r--r--install-location.patch14
4 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31cf29c47a96..e1fa1bbd0d8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libroboint
pkgdesc = libroboint is an Open Source version of the fischertechnik ROBO Interface Library for Unix like systems
pkgver = 0.5.5
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/Humpelstilzchen/libroboint
arch = x86_64
arch = arm
@@ -13,7 +13,7 @@ pkgbase = libroboint
source = https://gitlab.com/Humpelstilzchen/libroboint/-/archive/0.5.5/libroboint-0.5.5.tar.gz
source = install-location.patch
md5sums = b30d38681449840f1174573bcd310ae1
- md5sums = 655be9776e307e816e936445f00551e5
+ md5sums = 925ec938a574e6e2f9fb7b5a894a35c9
pkgname = libroboint
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5bc2aa573e1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 614120567b57..c2fc0c4c3a3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Frank Boerman <frank@fboerman.nl>
pkgname=libroboint
pkgver=0.5.5
-pkgrel=1
+pkgrel=2
pkgdesc="libroboint is an Open Source version of the fischertechnik ROBO Interface Library for Unix like systems"
arch=('x86_64' 'arm')
url="https://gitlab.com/Humpelstilzchen/libroboint"
@@ -11,7 +11,7 @@ optdepends=('libroboint-python: python bindings')
makedepends=('cmake' 'gcc')
source=("https://gitlab.com/Humpelstilzchen/libroboint/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
"install-location.patch")
-md5sums=("b30d38681449840f1174573bcd310ae1" "655be9776e307e816e936445f00551e5")
+md5sums=("b30d38681449840f1174573bcd310ae1" "925ec938a574e6e2f9fb7b5a894a35c9")
prepare() {
cd "$pkgname-$pkgver"
@@ -27,4 +27,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
make install
+ make udev
}
diff --git a/install-location.patch b/install-location.patch
index a5e8225a5fe9..88b78159b262 100644
--- a/install-location.patch
+++ b/install-location.patch
@@ -1,3 +1,16 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 581d7f5..6546f2d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -73,7 +73,7 @@ ELSE (DOXYGEN_INSTALLED)
+ MESSAGE(STATUS "Unable to create documentation!")
+ ENDIF (DOXYGEN_INSTALLED)
+
+-ADD_CUSTOM_TARGET(udev COMMAND ${CMAKE_COMMAND} -E copy udev/fischertechnik.rules /etc/udev/rules.d/fischertechnik.rules)
++ADD_CUSTOM_TARGET(udev COMMAND ${CMAKE_COMMAND} -E copy udev/fischertechnik.rules ${CMAKE_INSTALL_PREFIX}/etc/udev/rules.d/fischertechnik.rules)
+
+ ADD_DEFINITIONS(-DLIBROBOINT_VERSION_MAJOR=${CPACK_PACKAGE_VERSION_MAJOR})
+ ADD_DEFINITIONS(-DLIBROBOINT_VERSION_MINOR=${CPACK_PACKAGE_VERSION_MINOR})
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 878e901..8e060b7 100644
--- a/lib/CMakeLists.txt
@@ -23,4 +36,3 @@ index 8b3f3d5..337aacc 100644
-INSTALL_TARGETS(/bin ftuploader)
+INSTALL_TARGETS(/usr/bin ftuploader)
-