summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Boerman2021-01-13 19:52:28 +0100
committerFrank Boerman2021-01-13 19:52:28 +0100
commitc108148f589df6ae02bc3bfdf5a24153f942079b (patch)
tree277914e750c2a8b27e29b744c8bb699af1db6354
downloadaur-c108148f589df6ae02bc3bfdf5a24153f942079b.tar.gz
first working build
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--install-location.patch26
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de25ae554525
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libroboint
+ pkgdesc = libroboint is an Open Source version of the fischertechnik ROBO Interface Library for Unix like systems
+ pkgver = 0.5.5
+ pkgrel = 1
+ url = https://gitlab.com/Humpelstilzchen/libroboint
+ arch = x86_64
+ arch = arm
+ license = LGPLv2.1
+ makedepends = cmake
+ makedepends = gcc
+ depends = libusb-compat
+ source = https://gitlab.com/Humpelstilzchen/libroboint/-/archive/0.5.5/libroboint-0.5.5.tar.gz
+ source = install-location.patch
+ md5sums = b30d38681449840f1174573bcd310ae1
+ md5sums = 655be9776e307e816e936445f00551e5
+
+pkgname = libroboint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18e8a8e7df98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Frank Boerman <frank@fboerman.nl>
+pkgname=libroboint
+pkgver=0.5.5
+pkgrel=1
+pkgdesc="libroboint is an Open Source version of the fischertechnik ROBO Interface Library for Unix like systems"
+arch=('x86_64' 'arm')
+url="https://gitlab.com/Humpelstilzchen/libroboint"
+license=('LGPLv2.1')
+depends=('libusb-compat')
+makedepends=('cmake' 'gcc')
+source=("https://gitlab.com/Humpelstilzchen/libroboint/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ "install-location.patch")
+md5sums=("b30d38681449840f1174573bcd310ae1" "655be9776e307e816e936445f00551e5")
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/install-location.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=$pkgdir/ .
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install
+}
diff --git a/install-location.patch b/install-location.patch
new file mode 100644
index 000000000000..a5e8225a5fe9
--- /dev/null
+++ b/install-location.patch
@@ -0,0 +1,26 @@
+diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
+index 878e901..8e060b7 100644
+--- a/lib/CMakeLists.txt
++++ b/lib/CMakeLists.txt
+@@ -4,8 +4,8 @@ FIND_PACKAGE(Threads REQUIRED)
+ FIND_PACKAGE(LIBUSB REQUIRED)
+
+ add_library(roboint SHARED libroboint.c crc.c)
+-install(TARGETS roboint DESTINATION lib)
+-install(FILES roboint.h DESTINATION include/)
++install(TARGETS roboint DESTINATION usr/lib)
++install(FILES roboint.h DESTINATION usr/include/)
+ TARGET_LINK_LIBRARIES(roboint ${CMAKE_THREAD_LIBS_INIT} ${LIBUSB_LIBRARIES})
+ INCLUDE_DIRECTORIES(${LIBUSB_INCLUDE_DIR})
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 8b3f3d5..337aacc 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -4,4 +4,4 @@ add_executable(ftuploader ftuploader.c)
+
+ target_link_libraries(ftuploader roboint)
+
+-INSTALL_TARGETS(/bin ftuploader)
++INSTALL_TARGETS(/usr/bin ftuploader)
+