summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEden Rose2017-08-26 01:28:48 -0400
committerEden Rose2017-08-26 01:28:48 -0400
commit8dccec433c1c060f800920d16dfe2fb4420105c6 (patch)
treee6e48820a27cefbd0aba11c1a4e40bc2a3e4ff71
downloadaur-8dccec433c1c060f800920d16dfe2fb4420105c6.tar.gz
Initial Commit; No Version Info.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a088c205b89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = librocket-git
+ pkgdesc = The HTML/CSS User Interface library
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = http://librocket.com
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = mesa
+ depends = boost
+ depends = freetype2
+ depends = python2
+ depends = libgl
+ depends = glu
+ provides = librocket
+ provides = librocket-git
+ conflicts = librocket
+ source = librocket-git::git+https://github.com/libRocket/libRocket.git
+ sha256sums = SKIP
+
+pkgname = librocket-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa97c2494494
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Eden Rose <eenov1988@gmail.com>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Eugene Tan <jmingtan at gmail dot com>
+
+pkgname=librocket-git
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="The HTML/CSS User Interface library"
+arch=('i686' 'x86_64')
+url="http://librocket.com"
+license=('MIT')
+depends=('boost' 'freetype2' 'python2' 'libgl' 'glu')
+makedepends=('cmake' 'mesa')
+conflicts=('librocket')
+provides=('librocket' "$pkgname")
+source=("$pkgname::git+https://github.com/libRocket/libRocket.git")
+sha256sums=('SKIP')
+
+#prepare() {
+# # fix samples folder
+# sed 's|opt/Rocket/Samples|share/librocket/samples|' -i \
+# libRocket-release-$pkgver/Build/CMakeLists.txt
+#}
+
+build() {
+ cd $pkgname/Build
+ cmake -DCMAKE_INSTALL_PREFIX="" -DBUILD_SAMPLES=ON \
+ -DBUILD_PYTHON_BINDINGS=ON -DPYTHON_EXECUTABLE=/usr/bin/python2 .
+ make
+}
+
+package() {
+ cd $pkgname
+ make -C Build install DESTDIR="$pkgdir/usr"
+
+ # doc
+ install -d "$pkgdir"/usr/share/doc/librocket
+ install -m644 readme.md changelog.txt "$pkgdir"/usr/share/doc/librocket
+ # license
+ install -d "$pkgdir"/usr/share/licenses/librocket
+ tail -n20 readme.md > "$pkgdir"/usr/share/licenses/librocket/LICENSE.md
+}