summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Baumann2023-09-15 09:40:28 +0200
committerAndreas Baumann2023-09-15 09:40:28 +0200
commit0b1c398e04f3c44170fb10ce9fbc3e4e2381971f (patch)
treec05b75a9115f7438c2de9edb0ff1914765f1bcd2
parent931e834891fae79f8cf3c56718b5bbd469cd1fe8 (diff)
downloadaur-0b1c398e04f3c44170fb10ce9fbc3e4e2381971f.tar.gz
librsvg-og: synched with Arch32 repo
-rw-r--r--PKGBUILD33
1 files changed, 23 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c08854e42a28..72b5a26a94bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,38 @@
# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
pkgname=librsvg-og
-pkgver=2.40.20
-pkgrel=1
+pkgver=2.40.20+23+g0f3eef9e
+pkgrel=3
epoch=1
pkgdesc="SVG rendering library old gen"
url="https://github.com/oaken-source/librsvg-og"
-arch=(i486 i686 pentium4)
+arch=(i486 i686 pentium4 x86_64)
license=(LGPL)
-depends=(gdk-pixbuf2 pango)
+depends=(gdk-pixbuf2 pango libcroco)
conflicts_i486=(libsrvg)
makedepends=(gobject-introspection gtk-doc git)
provides_i486=(librsvg=${pkgver} librsvg-${pkgver%%.*}.so)
-source=("https://github.com/oaken-source/librsvg-og/archive/2.40.20.tar.gz")
-sha256sums=('5bcbd8aa34a81478f990dc62a308ee2a42ff89a4e2bc905c09fd68f525bf5643')
+#source=("https://github.com/oaken-source/librsvg-og/archive/2.40.20.tar.gz")
+_commit=0f3eef9e6924130c74d7a7b16aac3e7f5bef9b4c # branch api2
+source=("git+https://github.com/andreasbaumann/librsvg-og.git#commit=$_commit")
+
+#sha256sums=('5bcbd8aa34a81478f990dc62a308ee2a42ff89a4e2bc905c09fd68f525bf5643')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/^orc-//;s/-/+/g'
+}
prepare() {
- cd ${pkgname}-${pkgver}
+# cd ${pkgname}-${pkgver}
+ cd $pkgname
NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd ${pkgname}-${pkgver}
+# cd ${pkgname}-${pkgver}
+ cd $pkgname
./configure --prefix=/usr --disable-static --disable-vala \
--enable-gtk-doc
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' libtool
@@ -29,13 +40,15 @@ build() {
}
check() {
- cd ${pkgname}-${pkgver}
+# cd ${pkgname}-${pkgver}
+ cd $pkgname
# Test suite is very dependent on the versions of
# Cairo, Pango, FreeType and HarfBuzz
make check || :
}
package() {
- cd ${pkgname}-${pkgver}
+# cd ${pkgname}-${pkgver}
+ cd $pkgname
make DESTDIR="$pkgdir" install
}