summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavidLazarescu2023-08-25 20:53:46 +0200
committerDavidLazarescu2023-08-25 20:53:46 +0200
commit84a0dbcc2b2fbdedb7a43a6781fa4a9362310731 (patch)
tree4534d21ea54c62280e24af469ec9c2cf5c0ad69e
parent236a746175499b86fdc18de8409a313642b1c77f (diff)
downloadaur-84a0dbcc2b2fbdedb7a43a6781fa4a9362310731.tar.gz
Removed explicit installing of librum.desktop file
This is now done automatically by invoking 'cmake --install'
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c40d6e7f576c..6da22521c324 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = librum
pkgdesc = A modern e-book reader and library manager
pkgver = v.0.6.3.r14.g6774c2c
- pkgrel = 8
+ pkgrel = 9
url = https://librumreader.com
arch = x86_64
license = GPL3
@@ -9,7 +9,6 @@ pkgbase = librum
makedepends = make
makedepends = cmake
makedepends = gcc
- makedepends = desktop-file-utils
makedepends = unzip
makedepends = python3
depends = qt6-base
diff --git a/PKGBUILD b/PKGBUILD
index ffc80bd440cc..db5debeb59ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: David Lazarescu <prtnprvtmail@protonmail.com>
pkgname='librum'
pkgver=v.0.6.3.r14.g6774c2c
-pkgrel=8
+pkgrel=9
pkgdesc="A modern e-book reader and library manager"
arch=(x86_64)
url="https://librumreader.com"
license=('GPL3')
depends=('qt6-base' 'qt6-declarative' 'qt6-svg' 'gcc-libs' 'glibc' 'krb5' 'brotli' 'zstd' 'zlib' 'libproxy' 'libglvnd' 'libx11' 'glib2' 'libxkbcommon' 'libpng' 'harfbuzz' 'md4c' 'freetype2' 'systemd-libs' 'double-conversion' 'libb2' 'pcre2' 'openssl' 'e2fsprogs' 'keyutils' 'expat' 'libxcb' 'dbus' 'graphite' 'bzip2' 'libcap' 'libgcrypt' 'xz' 'lz4' 'curl' 'duktape' 'libffi' 'libxau' 'libxdmcp' 'libgpg-error' 'libnghttp2' 'libidn2' 'libpsl' 'util-linux-libs' 'libunistring')
-makedepends=('git' 'make' 'cmake' 'gcc' 'desktop-file-utils' 'unzip' 'python3')
+makedepends=('git' 'make' 'cmake' 'gcc' 'unzip' 'python3')
source=(Librum::"git+https://github.com/Librum-Reader/Librum.git")
md5sums=('SKIP')
@@ -31,5 +31,4 @@ build() {
package() {
cd "Librum"
DESTDIR="$pkgdir" cmake --install .
- desktop-file-install librum.desktop --dir="${pkgdir}/usr/share/applications/"
}