summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavidLazarescu2023-08-24 00:04:17 +0200
committerDavidLazarescu2023-08-24 00:04:17 +0200
commit9b32802229e78aaf863f614725043fe289a64b70 (patch)
treee333464978b93c4feab232d72d1f1bd114103237
parentc5973c78e82e4b34acefe5a05068d64fa7b0e5c0 (diff)
downloadaur-9b32802229e78aaf863f614725043fe289a64b70.tar.gz
Switched back to make due to dependency from mupdf
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 360ff7fa82fc..8df6854d9f8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = librum
pkgdesc = A modern e-book reader and library manager
pkgver = v.0.6.3.r14.g6774c2c
- pkgrel = 7
+ pkgrel = 8
url = https://librumreader.com
arch = x86_64
license = GPL3
makedepends = git
- makedepends = ninja
+ makedepends = make
makedepends = cmake
makedepends = gcc
makedepends = unzip
diff --git a/PKGBUILD b/PKGBUILD
index fef51acf76a2..ea1ea7178572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: David Lazarescu <prtnprvtmail@protonmail.com>
pkgname='librum'
pkgver=v.0.6.3.r14.g6774c2c
-pkgrel=7
+pkgrel=8
pkgdesc="A modern e-book reader and library manager"
arch=(x86_64)
url="https://librumreader.com"
license=('GPL3')
depends=('qt6-base' 'qt6-declarative' 'qt6-svg' 'gcc-libs' 'glibc' 'krb5' 'brotli' 'zstd' 'zlib' 'libproxy' 'libglvnd' 'libx11' 'glib2' 'libxkbcommon' 'libpng' 'harfbuzz' 'md4c' 'freetype2' 'systemd-libs' 'double-conversion' 'libb2' 'pcre2' 'openssl' 'e2fsprogs' 'keyutils' 'expat' 'libxcb' 'dbus' 'graphite' 'bzip2' 'libcap' 'libgcrypt' 'xz' 'lz4' 'curl' 'duktape' 'libffi' 'libxau' 'libxdmcp' 'libgpg-error' 'libnghttp2' 'libidn2' 'libpsl' 'util-linux-libs' 'libunistring')
-makedepends=('git' 'ninja' 'cmake' 'gcc' 'unzip' 'python3')
+makedepends=('git' 'make' 'cmake' 'gcc' 'unzip' 'python3')
source=(Librum::"git+https://github.com/Librum-Reader/Librum.git")
md5sums=('SKIP')
@@ -24,7 +24,7 @@ prepare() {
build() {
cd "Librum"
- cmake -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTS=Off .
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTS=Off .
cmake --build .
}