summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-11-28 13:41:48 -0700
committerMark Wagie2020-11-28 13:41:48 -0700
commit130c888217fd5b1c1bdb7e745d480b941f07e3b3 (patch)
treebabc1992e7e12bfc8323554c3cb310c464dc4d17
downloadaur-130c888217fd5b1c1bdb7e745d480b941f07e3b3.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD32
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6963eed83ba3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libs76-hidpi-widget-git
+ pkgdesc = System76 HiDPI daemon widget library
+ pkgver = r12.1b9ddd8
+ pkgrel = 1
+ url = https://github.com/pop-os/hidpi-widget
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = rust
+ depends = gtk3
+ depends = system76-hidpi-daemon
+ provides = libs76-hidpi-widget
+ conflicts = libs76-hidpi-widget
+ source = git+https://github.com/pop-os/hidpi-widget.git
+ sha256sums = SKIP
+
+pkgname = libs76-hidpi-widget-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..534aa442165b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=libs76-hidpi-widget-git
+pkgver=r12.1b9ddd8
+pkgrel=1
+pkgdesc="System76 HiDPI daemon widget library"
+arch=('x86_64')
+url="https://github.com/pop-os/hidpi-widget"
+license=('GPL3')
+depends=('gtk3' 'system76-hidpi-daemon')
+makedepends=('git' 'rust')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/pop-os/hidpi-widget.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/hidpi-widget"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/hidpi-widget"
+ cargo build --release
+ cargo build --release --manifest-path ffi/Cargo.toml
+ cargo run -p tools --bin pkgconfig -- \
+ s76_hidpi_widget /usr/lib /usr/include
+}
+
+package() {
+ cd "$srcdir/hidpi-widget"
+ make prefix=/usr DESTDIR="$pkgdir/" install
+}