summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Ivanov2022-09-17 08:18:11 +0200
committerPeter Ivanov2022-09-17 08:18:11 +0200
commit468151e6d92d9a9a50ced1cdaa1e093f5911c27e (patch)
tree43dcc4b873be4a736a6dc5b1611930374fb2930f
parent28a4d28c02b1b060a751b596beb3e583a4814170 (diff)
downloadaur-468151e6d92d9a9a50ced1cdaa1e093f5911c27e.tar.gz
Updated to version 3.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f50a3b95f64a..6648481d3929 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = libsaasound
pkgdesc = Philips SAA1099 sound generator chip emulator
- pkgver = 3.2
- pkgrel = 2
+ pkgver = 3.4
+ pkgrel = 1
url = http://www.simcoupe.org/
arch = i686
arch = x86_64
license = GPL
makedepends = make
depends = sdl
- source = http://www.simcoupe.org/files/SAASound-3.2.tar.gz
- md5sums = 6a1e45f3f8958be6cfe88872cec3763f
+ source = https://github.com/simonowen/SAASound/archive/refs/tags/3.4.tar.gz
+ md5sums = 784340694e9d75f1364643a54d12eb7c
pkgname = libsaasound
-
diff --git a/PKGBUILD b/PKGBUILD
index 76e34fbaf850..d15ffcb3ea39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
# Maintainer: Peter Ivanov <ivanovp@gmail.com>
pkgname=libsaasound
-pkgver=3.2
-pkgrel=2
+pkgver=3.4
+pkgrel=1
pkgdesc="Philips SAA1099 sound generator chip emulator"
arch=('i686' 'x86_64')
url="http://www.simcoupe.org/"
license=('GPL')
depends=('sdl')
makedepends=('make')
-source=("http://www.simcoupe.org/files/SAASound-${pkgver}.tar.gz")
+source=("https://github.com/simonowen/SAASound/archive/refs/tags/${pkgver}.tar.gz")
+md5sums=('784340694e9d75f1364643a54d12eb7c')
build() {
cd "$srcdir/SAASound-${pkgver}"
- ./configure --prefix=$pkgdir/usr
+ cmake . -DCMAKE_INSTALL_PREFIX=$pkgdir/usr
make
}
package() {
- install -m755 -d $pkgdir/usr/lib/{include,lib}
+ install -m755 -d $pkgdir/usr/{include,lib}
cd "$srcdir/SAASound-${pkgver}"
make install
}
-md5sums=('6a1e45f3f8958be6cfe88872cec3763f')
-
# vim:set sts=2 ts=2 sw=2 et: