summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2024-04-06 13:11:54 +0200
committerMarcell Meszaros2024-04-06 13:14:20 +0200
commit54ac1767f2c061b180fc618eb312d4f7c4426ce8 (patch)
tree9e5ddc4f7488996df3daf092af6c65a950c533cc
parente34073b44eb1804263dd4fe9be1cdec6312169b5 (diff)
downloadaur-54ac1767f2c061b180fc618eb312d4f7c4426ce8.tar.gz
5.3.0-0.1: WiP update, but CMake build is broken due to upstream transitioning to conan
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD23
-rw-r--r--use_system_pugixml.patch22
4 files changed, 36 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d55355d9148a..43ecec5065a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = libsavitar
pkgdesc = C++ implementation of 3mf loading with SIP python bindings
- pkgver = 4.13.0
- pkgrel = 1
+ pkgver = 5.3.0
+ pkgrel = 0.1
url = https://github.com/Ultimaker/libsavitar
arch = x86_64
license = AGPL
makedepends = cmake
- makedepends = python-sip4
- makedepends = sip4
+ makedepends = ninja
+ makedepends = python-pyqt5-sip
+ makedepends = sip
depends = python
depends = pugixml
- source = libsavitar-4.13.0.tar.gz::https://github.com/Ultimaker/libSavitar//archive/4.13.0.tar.gz
- source = use_system_pugixml.patch
- sha512sums = a446131c0bbcc34e55c093032af823b9750797f06297bea9fd4d64838e793811e71679a1f6ae99be9fc9382a23e8763140147c7a6eea0a310f6f2d40b53be3bf
- sha512sums = b312dcf43bf334001da98da93388da99731eacf417fe3a9dff51831bdd1f0ab5487377925bebce05e227533be2680b1a45f3203b0a7b9de9a77280a206ec7b26
+ source = libsavitar-5.3.0.tar.gz::https://github.com/Ultimaker/libSavitar//archive/5.3.0.tar.gz
+ b2sums = fa9c745c6f86940e87e99b08d7ddbc933fe5e56cac583da9ecb7673efc7ce63de4be9729f4108e1de9867bd1d4cad311da6c2c3707d9ab075dcf873cc41a0bad
pkgname = libsavitar
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..058ba2318df1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+# based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+
+*/
+*.orig
+*.bak
+*.backup
+*.kate-swp
+.directory
diff --git a/PKGBUILD b/PKGBUILD
index efed0c8c3831..aacb4f4b0038 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
-# Maintainer: Jelle van der Waa <jelle@archlinux.org>
+# Contributor: Jelle van der Waa <jelle@archlinux.org>
# Contributor: neodarz <neodarz@neodarz.net>
pkgname=libsavitar
-pkgver=4.13.0
-pkgrel=1
+pkgver=5.3.0
+pkgrel=0.1
pkgdesc="C++ implementation of 3mf loading with SIP python bindings"
arch=('x86_64')
url="https://github.com/Ultimaker/libsavitar"
license=('AGPL')
depends=('python' 'pugixml')
-makedepends=('cmake' 'python-sip4' 'sip4')
-source=($pkgname-$pkgver.tar.gz::https://github.com/Ultimaker/libSavitar//archive/${pkgver}.tar.gz use_system_pugixml.patch)
-sha512sums=('a446131c0bbcc34e55c093032af823b9750797f06297bea9fd4d64838e793811e71679a1f6ae99be9fc9382a23e8763140147c7a6eea0a310f6f2d40b53be3bf'
- 'b312dcf43bf334001da98da93388da99731eacf417fe3a9dff51831bdd1f0ab5487377925bebce05e227533be2680b1a45f3203b0a7b9de9a77280a206ec7b26')
+makedepends=(
+ 'cmake'
+ 'ninja'
+ 'python-pyqt5-sip'
+ 'sip'
+)
+source=($pkgname-$pkgver.tar.gz::https://github.com/Ultimaker/libSavitar//archive/${pkgver}.tar.gz)
+b2sums=('fa9c745c6f86940e87e99b08d7ddbc933fe5e56cac583da9ecb7673efc7ce63de4be9729f4108e1de9867bd1d4cad311da6c2c3707d9ab075dcf873cc41a0bad')
prepare() {
cd "libSavitar-${pkgver}"
sed -i 's,DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages,DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages,g' CMakeLists.txt
sed -i 's,DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages/cura),DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages/cura),g' CMakeLists.txt
-
- # don't install a second system pugixml; WONTFIX upstream due to:
- # "It's been decided that an external dependency makes setting up your
- # development environment for Cura needlessly difficult."
- patch -Np1 -i "$srcdir"/use_system_pugixml.patch
}
build() {
diff --git a/use_system_pugixml.patch b/use_system_pugixml.patch
deleted file mode 100644
index 841c016df07e..000000000000
--- a/use_system_pugixml.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From b76fcd6da723cc725f2703d6c1b82b954a1bd03a Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Gabriel=20F=C3=A9ron?= <feron.gabriel@gmail.com>
-Date: Tue, 18 Jun 2019 22:45:17 +0200
-Subject: [PATCH] Don't build pugixml
-
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index eecd5e9..7ec2b2b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -15,8 +15,6 @@ if(BUILD_TESTS)
- find_package(Threads QUIET)
- endif()
-
--add_subdirectory(pugixml)
--
- if(BUILD_PYTHON)
- list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
-
---
-2.21.0
-