summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2021-04-07 00:39:41 -0400
committerAdam Goldsmith2021-04-07 00:39:41 -0400
commit69fe0aed8cbea4524fedc5b5b96665c17281b663 (patch)
tree47c96149f47397a9d9ea3737235b5d29c7a52ff8
parentfa9b7ce6f5d8d35d4118dc04111c977ac6988b9f (diff)
downloadaur-69fe0aed8cbea4524fedc5b5b96665c17281b663.tar.gz
Replace sip/python-sip with sip4/python-sip4, update pugixml patch
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Do-not-vendor-the-pugixml-library.patch85
-rw-r--r--PKGBUILD10
3 files changed, 95 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e5973731633..cd5a896996c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = libsavitar-git
pkgdesc = c++ implementation of 3mf loading with SIP python bindings
- pkgver = 3.4.1.r0.g62dd545
+ pkgver = 4.9.beta.r0.gfe88675
pkgrel = 1
url = https://github.com/Ultimaker/libSavitar
arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
- makedepends = python-sip
- makedepends = sip
+ makedepends = python-sip4
+ makedepends = sip4
makedepends = git
depends = python
depends = pugixml
provides = libsavitar
conflicts = libsavitar
source = git+https://github.com/Ultimaker/libSavitar.git
- source = https://github.com/Ultimaker/libSavitar/pull/8/commits/91aa70c6320461ae65600dce954b5ffb905b7039.patch
+ source = 0001-Do-not-vendor-the-pugixml-library.patch
md5sums = SKIP
- md5sums = 8cb2ef4a8ff551114ac8520c6be42ec6
+ md5sums = 1d0e2c14874414202eba249d956ada56
pkgname = libsavitar-git
diff --git a/0001-Do-not-vendor-the-pugixml-library.patch b/0001-Do-not-vendor-the-pugixml-library.patch
new file mode 100644
index 000000000000..8b9834725ab5
--- /dev/null
+++ b/0001-Do-not-vendor-the-pugixml-library.patch
@@ -0,0 +1,85 @@
+From c436082126399a8b48ea763f26a3d1434b40728f Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Mon, 9 Apr 2018 12:36:35 -0400
+Subject: [PATCH] Do not vendor the pugixml library
+
+This prevents trying to co-install pugixml with existing system
+libraries, and also fixes the includes for pugixml.hpp to actually use
+the include path added by find_package/add_subdirectory instead of a
+hardcoded relative path.
+---
+ CMakeLists.txt | 2 +-
+ src/MeshData.cpp | 2 +-
+ src/Scene.cpp | 2 +-
+ src/SceneNode.cpp | 2 +-
+ src/ThreeMFParser.h | 2 +-
+ 5 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f22d42e..e78b1f8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,7 +15,7 @@ if(BUILD_TESTS)
+ find_package(Threads QUIET)
+ endif()
+
+-add_subdirectory(pugixml)
++find_package(pugixml REQUIRED)
+
+ if(BUILD_PYTHON)
+ list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
+diff --git a/src/MeshData.cpp b/src/MeshData.cpp
+index 97c089a..7c4de46 100644
+--- a/src/MeshData.cpp
++++ b/src/MeshData.cpp
+@@ -17,7 +17,7 @@
+ */
+
+ #include "MeshData.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+ #include <cstring>
+ #include <iostream>
+ #include <stdexcept> //For std::runtime_error.
+diff --git a/src/Scene.cpp b/src/Scene.cpp
+index 7a40570..86e9295 100644
+--- a/src/Scene.cpp
++++ b/src/Scene.cpp
+@@ -17,7 +17,7 @@
+ */
+
+ #include "Scene.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+ #include <iostream>
+ #include <string>
+ using namespace Savitar;
+diff --git a/src/SceneNode.cpp b/src/SceneNode.cpp
+index db686e9..8c9dd8c 100644
+--- a/src/SceneNode.cpp
++++ b/src/SceneNode.cpp
+@@ -18,7 +18,7 @@
+
+ #include "SceneNode.h"
+ #include "Namespace.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+ #include <iostream>
+ using namespace Savitar;
+
+diff --git a/src/ThreeMFParser.h b/src/ThreeMFParser.h
+index 3394683..a0f6691 100644
+--- a/src/ThreeMFParser.h
++++ b/src/ThreeMFParser.h
+@@ -21,7 +21,7 @@
+
+ #include "SavitarExport.h"
+ #include "SceneNode.h"
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+
+ #include <string>
+ namespace Savitar
+--
+2.31.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 09dea34dce98..7f7e0d3488f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,20 @@
pkgname=libsavitar-git
_pkgname=libSavitar
-pkgver=3.4.1.r0.g62dd545
+pkgver=4.9.beta.r0.gfe88675
pkgrel=1
pkgdesc="c++ implementation of 3mf loading with SIP python bindings"
arch=('i686' 'x86_64')
url="https://github.com/Ultimaker/$_pkgname"
license=('LGPL')
depends=('python' 'pugixml')
-makedepends=('cmake' 'python-sip' 'sip' 'git')
+makedepends=('cmake' 'python-sip4' 'sip4' 'git')
provides=('libsavitar')
conflicts=('libsavitar')
source=("git+https://github.com/Ultimaker/$_pkgname.git"
- "https://github.com/Ultimaker/libSavitar/pull/8/commits/91aa70c6320461ae65600dce954b5ffb905b7039.patch")
+ "0001-Do-not-vendor-the-pugixml-library.patch")
md5sums=('SKIP'
- '8cb2ef4a8ff551114ac8520c6be42ec6')
+ '1d0e2c14874414202eba249d956ada56')
pkgver() {
cd "${_pkgname}"
@@ -31,7 +31,7 @@ prepare() {
# don't install a second system pugixml; WONTFIX upstream due to:
# "It's been decided that an external dependency makes setting up your
# development environment for Cura needlessly difficult."
- patch -Np1 -i "$srcdir"/91aa70c6320461ae65600dce954b5ffb905b7039.patch
+ patch -Np1 -i "$srcdir"/0001-Do-not-vendor-the-pugixml-library.patch
}
build() {