summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOnline1222282023-07-23 01:14:43 +0200
committerOnline1222282023-07-23 01:14:43 +0200
commit7e5dab4eb73202cc32260f0675f81699f0ed04b7 (patch)
tree87220375cbb386a696ef97fdf0a6d8d25c49816a
parente81c9d33c276b1fdfe53e7e9c9bc37342cbc1f15 (diff)
downloadaur-7e5dab4eb73202cc32260f0675f81699f0ed04b7.tar.gz
tried removing that patch
-rw-r--r--0001-Do-not-vendor-the-pugixml-library.patch127
-rw-r--r--PKGBUILD5
2 files changed, 0 insertions, 132 deletions
diff --git a/0001-Do-not-vendor-the-pugixml-library.patch b/0001-Do-not-vendor-the-pugixml-library.patch
deleted file mode 100644
index 5a0dc7b942b8..000000000000
--- a/0001-Do-not-vendor-the-pugixml-library.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-From 021d0732750cddee97e771814e5e2ca17585db46 Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz93@gmail.com>
-Date: Mon, 9 Apr 2018 12:36:35 -0400
-Subject: [PATCH] Do not vendor the pugixml library
-
-This prevents trying to co-install pugixml with existing system
-libraries, and also fixes the includes for pugixml.hpp to actually use
-the include path added by find_package/add_subdirectory instead of a
-hardcoded relative path.
----
- CMakeLists.txt | 2 +-
- src/MeshData.cpp | 2 +-
- src/Namespace.cpp | 2 +-
- src/Scene.cpp | 2 +-
- src/SceneNode.cpp | 2 +-
- src/ThreeMFParser.h | 2 +-
- tests/MeshDataTest.cpp | 2 +-
- tests/NamespaceTest.cpp | 2 +-
- 8 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f22d42e..e78b1f8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -15,7 +15,7 @@ if(BUILD_TESTS)
- find_package(Threads QUIET)
- endif()
-
--add_subdirectory(pugixml)
-+find_package(pugixml REQUIRED)
-
- if(BUILD_PYTHON)
- list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
-diff --git a/src/MeshData.cpp b/src/MeshData.cpp
-index 97c089a..7c4de46 100644
---- a/src/MeshData.cpp
-+++ b/src/MeshData.cpp
-@@ -17,7 +17,7 @@
- */
-
- #include "MeshData.h"
--#include "../pugixml/src/pugixml.hpp"
-+#include <pugixml.hpp>
- #include <cstring>
- #include <iostream>
- #include <stdexcept> //For std::runtime_error.
-diff --git a/src/Namespace.cpp b/src/Namespace.cpp
-index 2cfff76..23c3349 100644
---- a/src/Namespace.cpp
-+++ b/src/Namespace.cpp
-@@ -3,7 +3,7 @@
-
- #include "Namespace.h"
-
--#include "../pugixml/src/pugixml.hpp"
-+#include <pugixml.hpp>
-
- namespace xml_namespace
- {
-diff --git a/src/Scene.cpp b/src/Scene.cpp
-index 7a40570..86e9295 100644
---- a/src/Scene.cpp
-+++ b/src/Scene.cpp
-@@ -17,7 +17,7 @@
- */
-
- #include "Scene.h"
--#include "../pugixml/src/pugixml.hpp"
-+#include <pugixml.hpp>
- #include <iostream>
- #include <string>
- using namespace Savitar;
-diff --git a/src/SceneNode.cpp b/src/SceneNode.cpp
-index db686e9..8c9dd8c 100644
---- a/src/SceneNode.cpp
-+++ b/src/SceneNode.cpp
-@@ -18,7 +18,7 @@
-
- #include "SceneNode.h"
- #include "Namespace.h"
--#include "../pugixml/src/pugixml.hpp"
-+#include <pugixml.hpp>
- #include <iostream>
- using namespace Savitar;
-
-diff --git a/src/ThreeMFParser.h b/src/ThreeMFParser.h
-index 3394683..a0f6691 100644
---- a/src/ThreeMFParser.h
-+++ b/src/ThreeMFParser.h
-@@ -21,7 +21,7 @@
-
- #include "SavitarExport.h"
- #include "SceneNode.h"
--#include "../pugixml/src/pugixml.hpp"
-+#include <pugixml.hpp>
-
- #include <string>
- namespace Savitar
-diff --git a/tests/MeshDataTest.cpp b/tests/MeshDataTest.cpp
-index 583b946..76d3187 100644
---- a/tests/MeshDataTest.cpp
-+++ b/tests/MeshDataTest.cpp
-@@ -10,7 +10,7 @@
- #include <iterator>
- #include <string>
-
--#include "../pugixml/src/pugixml.hpp"
-+#include <pugixml.hpp>
-
- namespace Savitar
- {
-diff --git a/tests/NamespaceTest.cpp b/tests/NamespaceTest.cpp
-index 1a2c2a2..4ac77fa 100644
---- a/tests/NamespaceTest.cpp
-+++ b/tests/NamespaceTest.cpp
-@@ -7,7 +7,7 @@
- #include <gtest/gtest.h>
- #include <iostream>
- #include <string>
--#include "../pugixml/src/pugixml.hpp"
-+#include <pugixml.hpp>
-
- namespace xml_namespace
- {
---
-2.31.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 93a7a37a192b..550bacf9d324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,11 +29,6 @@ prepare() {
cd "${_pkgname}"
sed -i 's,DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages,DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages,g' CMakeLists.txt
sed -i 's,DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages/cura),DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages/cura),g' CMakeLists.txt
-
- # don't install a second system pugixml; WONTFIX upstream due to:
- # "It's been decided that an external dependency makes setting up your
- # development environment for Cura needlessly difficult."
- patch -Np1 -i "$srcdir"/0001-Do-not-vendor-the-pugixml-library.patch
}
build() {