summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McCurry2016-07-12 23:46:16 -0500
committerDan McCurry2016-07-12 23:46:16 -0500
commitbf927fdd643c4f609b5df9aece7198f373f63fff (patch)
tree7e31fcb2f6e48d0442ff09cfd089012ea050f5f2
parent897140d77d551d7b0da62da2d30837759bf25017 (diff)
downloadaur-bf927fdd643c4f609b5df9aece7198f373f63fff.tar.gz
Updated to version 1.95.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD38
2 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51dee4747946..f08578c72159 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = libsdrplay
pkgdesc = Modules for the SDRplay receiver
- pkgver = 1.9.4
- pkgrel = 2
+ pkgver = 1.95.1
+ pkgrel = 1
url = http://www.sdrplay.com
arch = i686
arch = x86_64
license = custom
depends = libusb>=1.0
- source = file://SDRplay_RSP_MiricsAPI-1.9.4.run
- md5sums = f4b56be5b91e95c839dd07595e2444f6
+ source = local://SDRplay_RSP_MiricsAPI-Linux-1.95.1.run
+ md5sums = 1913d6d48286ac7ff2b3a25386036ad4
pkgname = libsdrplay
diff --git a/PKGBUILD b/PKGBUILD
index 149ec18c478a..f4a03fe1dde7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
-#######################################
#
# The API used to connect to the SDRPlay is proprietary.
# To obtain the API, you must register your SDRPlay at
# http://www.sdrplay.com/starthere.php. You must download
-# the 'SDRplay_RSP_MiricsAPI-1.9.4.run' file but *do not*
+# the 'SDRplay_RSP_MiricsAPI-Linux-1.95.1.run' file but *do not*
# follow the remaining instructions (chmod 755, etc.)
# Instead copy the file to the same directory as the
# PKGBUILD and run makepkg.
@@ -15,38 +14,41 @@
# avoids installing the included outdated version of
# SoapySDR.
#
-#######################################
+
pkgname=libsdrplay
-pkgver=1.9.4
-pkgrel=2
+pkgver=1.95.1
+pkgrel=1
pkgdesc="Modules for the SDRplay receiver"
arch=('i686' 'x86_64')
url="http://www.sdrplay.com"
license=('custom')
depends=('libusb>=1.0')
-source=(file://SDRplay_RSP_MiricsAPI-1.9.4.run)
-md5sums=('f4b56be5b91e95c839dd07595e2444f6')
+source=("local://SDRplay_RSP_MiricsAPI-Linux-${pkgver}.run")
+md5sums=('1913d6d48286ac7ff2b3a25386036ad4')
prepare() {
- mkdir $pkgname
-
- # Strip the run file of superfluous scripts, untar, and extract license
- tail -n +499 SDRplay_RSP_MiricsAPI-1.9.4.run | tar -xzvf - -C ./$pkgname/
+ cd ${srcdir}
- # Pull out the license
- cd $pkgname
- cat mirsdrapi-rsp.h | grep Copyright > LICENSE
+ msg2 "Extracting makeself archive..."
+ sh SDRplay_RSP_MiricsAPI-Linux-${pkgver}.run --tar xf
+
+ msg2 "Writing license to LICENSE..."
+ sed -n 's/.*\(Copyright.*\)/\1/p' mirsdrapi-rsp.h > LICENSE
}
package() {
- cd "$pkgname"
+ cd "${srcdir}"
+
+ msg2 "Getting API version..."
+ _apivers=$(sed -n 's/export VERS="\(.*\)"/\1/p' install_lib.sh)
+ msg2 "API version ${_apivers}"
# These commands are equivalent to the scripts used in the supplied run file
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 libmirsdrapi-rsp-${CARCH}-1.8.1.so "${pkgdir}/usr/lib/libmirsdrapi-rsp-${CARCH}-1.8.1.so"
+ install -D -m644 libmirsdrapi-rsp-${CARCH}-${_apivers}.so "${pkgdir}/usr/lib/libmirsdrapi-rsp-${CARCH}-${_apivers}.so"
install -D -m644 mirsdrapi-rsp.h "${pkgdir}/usr/include/mirsdrapi-rsp.h"
install -D -m644 66-mirics.rules "${pkgdir}/etc/udev/rules.d/66-mirics.rules"
cd "${pkgdir}/usr/lib"
- ln -s libmirsdrapi-rsp-${CARCH}-1.8.1.so libmirsdrapi-rsp-1.8.1.so
- ln -s libmirsdrapi-rsp-${CARCH}-1.8.1.so libmirsdrapi-rsp.so
+ ln -s libmirsdrapi-rsp-${CARCH}-${_apivers}.so libmirsdrapi-rsp-${_apivers}.so
+ ln -s libmirsdrapi-rsp-${CARCH}-${_apivers}.so libmirsdrapi-rsp.so
}